Jump to content


- - - - -

Gplrank Submissions Problems?


  • Please log in to reply
11 replies to this topic

#1 DHosein

DHosein

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 310 posts
  • Gender:Male
  • Interests:GPL: TotalRank

Posted Nov 27 2010 - 01:37 PM

Is anyone else having problems submitting any non-GT times to GPLRank at the moment? Each time I try to submit any other file, I keep getting a 'null file or no length file error'..

#2 sky

sky

    ultra highres junkie & 917 addict

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,549 posts
  • Gender:Male
  • Location:the last haven for petrolheads
  • Interests:travel, music, racing, vintage cars, model cars
  • Sim interest:GPL

Posted Nov 27 2010 - 01:46 PM

nope. just uploaded a '69 file a bit earlier.

but what i noticed is that with the gt's rank the history function of uploaded times does not (seem to) work! when i click a time i get "no history, no history" :S

#3 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,825 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Nov 27 2010 - 03:49 PM

I just uploaded '65, '67 and '69 times (using the GPLRA "PB" feature) with no problem. What method are you using to upload your times Darren? Using GPLRA to scan for replays? Or submitting a player.ini file directly to GPLRank? If you're using the direct method, are you sure you're picking the player.ini file from the correct drivers' directory?

Edited by Saiph, Nov 27 2010 - 04:03 PM.


#4 DHosein

DHosein

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 310 posts
  • Gender:Male
  • Interests:GPL: TotalRank

Posted Nov 27 2010 - 04:58 PM

I'm using the player.ini direct... I've not been able to run GPLRA on my replays for a while - it seems to have issues with larger replay folders/files.

I've tried to tonight, my plac65.ini in my 65 driver folder and player.ini in my normal driver folder. Both are coming back with the same error.

Seems to be only those two that are causing me problems. Managed to submit 66s, 69s and Gts fine.

Edited by DHosein, Nov 27 2010 - 05:10 PM.


#5 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,825 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Nov 27 2010 - 07:22 PM

That's strange. My guess would be that the two files you're having problems with are corrupted in some way. Have you tried looking at them with a text editor to see if there's anything odd about them? Or it might be something to do with their sizes. My plac65.ini file is 30kB, and my '67 player.ini file is 81kB. Are your files larger than this?

#6 DHosein

DHosein

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 310 posts
  • Gender:Male
  • Interests:GPL: TotalRank

Posted Nov 28 2010 - 04:19 AM

I don't see anything different about the files in question, and they run through my new spreadsheet without problem. GPLRank for some reason is seeing them as empty.
They're not overly big, but they're definately not empty.

I've also tried deleting them altogether, creating a blank player.ini file from the game, and adding the times from GPLRank's generate .ini file feature and these don't work either.

Attached Files


Edited by DHosein, Nov 28 2010 - 04:27 AM.


#7 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,825 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Nov 28 2010 - 07:45 AM

View PostDHosein, on Nov 28 2010 - 04:19 AM, said:

......
They're not overly big, but they're definately not empty.
Wow! That's certainly an impressive collection of laps, Darren!  :thumbup:  

View PostDHosein, on Nov 28 2010 - 04:19 AM, said:

I've also tried deleting them altogether, creating a blank player.ini file from the game, and adding the times from GPLRank's generate .ini file feature and these don't work either.
Ok, having seen the size of your files, I think that's the most likely explanation of why you're having trouble. I would suggest trying two things:

  • Make a copy of one of the problem files, then delete half of the track entries (maybe just include tracks starting with A - M), and then try to upload it to GPLRank. If that works, add back half of the tracks you removed, bringing the total up to 75%, and upload again. Repeat this until you get fed up with it!  :D You might be able to find some kind of limit to the file size.

  • Use the email address on the GPLRank homepage to email Uwe and the other admins and let them know about the problem. Make sure you tell them about your file sizes. My guess is that the GPLRank website allocates a buffer area for uploaded files, and yours might be overflowing that buffer.

And good luck completing those last 49 laps to get your Monster of TotalRank - that would be a superb achievement!  :thumbup:  :clap2:

#8 Frenchy

Frenchy

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 28 2010 - 08:38 AM

Hi Darren

I recently had the same problem as you while trying to submit my 67 times using player.ini. After a moment of panic (I'd just reached a major milestone in my Monster Rank), I resaved my player.ini (after backing up) without making any changes and after that, all was well. Come to think of it, that was the first time I'd tried to upload 67 times after uploading GT times (placGT.ini from my GT player).

Perhaps there is some issue here.

Good luck
David

#9 DHosein

DHosein

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 310 posts
  • Gender:Male
  • Interests:GPL: TotalRank

Posted Nov 28 2010 - 10:19 AM

I managed to get all the times submitted eventually - by manually changing the player.ini files into a GPLRA extract.
Same number of laps was accepted first time in this format.

#10 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,825 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Nov 28 2010 - 10:27 AM

View PostDHosein, on Nov 28 2010 - 10:19 AM, said:

I managed to get all the times submitted eventually - by manually changing the player.ini files into a GPLRA extract.
Same number of laps was accepted first time in this format.
Glad you found a fix!  :thumbup:

#11 Arf Arf Arf

Arf Arf Arf

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 87 posts
  • Interests:4 wheels, 2 wheels
  • Sim interest:GPL

Posted Dec 16 2010 - 03:55 AM

I had a weird one last night. I uploaded some times to my GPL rank (ie the 67s), and when I looked at the changes some of my old times had disappeared. Nothing I've uploaded recently had changed (all rank improvements from last month are still there), but my best time at the ring (set 18 months ago) had gone, so my rank was 3.6 secs slower than it should have been.

I have amended my player.ini to correct this, but my Silverstone record has gone, and I'm not sure what that was (set on my old PC), so I'm reluctant to change it until I check it on that PC (but motivated to beat it...).

Any ideas how this could have happened?

Cheers

Arf

Edited by RickA, Dec 16 2010 - 04:12 AM.


#12 Frenchy

Frenchy

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Sim interest:GPL

Posted Dec 16 2010 - 04:52 AM

View PostRickA, on Dec 16 2010 - 03:55 AM, said:

I had a weird one last night. I uploaded some times to my GPL rank (ie the 67s), and when I looked at the changes some of my old times had disappeared. Nothing I've uploaded recently had changed (all rank improvements from last month are still there), but my best time at the ring (set 18 months ago) had gone, so my rank was 3.6 secs slower than it should have been.

I have amended my player.ini to correct this, but my Silverstone record has gone, and I'm not sure what that was (set on my old PC), so I'm reluctant to change it until I check it on that PC (but motivated to beat it...).

Any ideas how this could have happened?

Cheers

Arf

Hi Arf

I have had this happen to me in the past. I think my problem came about due to some replays not being present in my replay folder (from the days of uploading GPLRA reports).

Anyway just to remind you of the 'Generate ini file' feature of GPLRank which allows you to generate an ini file from any previous date. Once you've retrieved the missing time you can cut and paste it in to your player.ini.

... or you could just revisit the track in question and do a better time  :yeah:

Good luck
David




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links