Jump to content


- - - - -

Gpl Stuttering Sometimes.


  • Please log in to reply
30 replies to this topic

#1 Jumi2

Jumi2

    Erzkanzler

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 386 posts
  • Gender:Male
  • Location:Wooooohooo
  • Interests:Sports, Guitars.
  • Sim interest:GPL

Posted Oct 29 2010 - 04:57 AM

So lately i have driven some gpl again and enjoyed it immensely. I have some problems tho.

I use the newest patchs and updates, rasterizers and pribluda. All works very well when i drive with the 60fps patch, almost all times it is smooth and stays at 60fps.
Which is nice since i have a TFT display that has 60hz refresh rate, so with vsync enabled it is very enjoyable indead.

My woes start when i drive with the 36fps version of gpl, i tried with and without vsync but i still get little stutters that are from barely notable to big chops where it skips for a good bit, as much as half a second maybe. The weird thing is it stays smooth and good for some time and eventually skips. Maybe once or twice every minute. So i drive my lap and eventually it stutters.
Its a pain really, takes away a lot of fun, because you cant react to it or race properly with the fear of that happening.

My specs: dual core intel 3ghz, geforce 9800gtx+, 4gb ram, win xp sp3. so it should run fine. It happens in all mods and the original. Also d3d and ogl doesnt help.
I have the suspicion that it also is happening with chat messages, but am not sure since it also happens sometimes without any chat appearing.
Nothing runs in the background that could do it (also remember 60fps runs just fine)

Maybe someone clever has an idea how to at least reduce the amount gpl skips?

#2 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 29 2010 - 06:24 AM

Are you using Pribluda? Have you tried disabling pribluda (unpatch GPL.exe) to see if there's a difference?

Edited by Bernd Nowak, Oct 29 2010 - 06:24 AM.


#3 Jumi2

Jumi2

    Erzkanzler

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 386 posts
  • Gender:Male
  • Location:Wooooohooo
  • Interests:Sports, Guitars.
  • Sim interest:GPL

Posted Oct 29 2010 - 06:28 AM

Yes i am currently trying my way thru with all the 1110 1120 and 1121 version of pribluda and without.
It seems to give me the same performance. I must test more.

#4 M Needforspeed

M Needforspeed

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,464 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Oct 29 2010 - 06:32 AM

Jumi,




I suppose you have uninstalled and reinstalled your GFX videocard driver ? Check what driver you are using.Here, there is one that gave plain satisfaction , with GPL smooth as silk with 36 fps settings.I tried on TFT monitors with satisfaction, too.

driver for XP sp 3 : 258.98

Edited by M Needforspeed, Oct 29 2010 - 06:36 AM.


#5 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,296 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Oct 29 2010 - 08:30 AM

Stutters sometimes happen related to sound card issues.  Try disabling the sound card in system > hardware> device manager and driving without sound

#6 Rudy Dingemans

Rudy Dingemans

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 873 posts
  • Gender:Male
  • Location:Netherlands
  • Sim interest:GPL

Posted Oct 29 2010 - 11:51 AM

Also check your cache settings. I remember having serious stutter problems in GPL because those clever Microsoft programmers (cough) decided it was wise to always swap things to disk *before* using the RAM. This was in Win98, still, worth a check (Microsoft programmers usually don't get smarter over the years).


Regards, Rudy
(GPLRank: -40)

#7 Al Heller

Al Heller

    Bob Anderson

  • Members
  • PipPip
  • 17 posts
  • Sim interest:GPL

Posted Oct 30 2010 - 03:48 AM

View PostBob Simpson, on Oct 29 2010 - 08:30 AM, said:

Stutters sometimes happen related to sound card issues.  Try disabling the sound card in system > hardware> device manager and driving without sound

Yes as Bob says you should take a look at the sound card setup. I had the same micro stutters in GPL with a new high-spec PC & the culprit turned out to be the motherboard's onboard sound. I couldn't figure out a fix for it so in the end I disabled the onboard sound, then installed the ancient audigy 2 sound card out of my old PC & hey presto, GPL worked seamlessly after that.

Edited by Al Heller, Oct 30 2010 - 03:55 AM.


#8 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 30 2010 - 03:57 AM

View PostAl Heller, on Oct 30 2010 - 03:48 AM, said:

View PostBob Simpson, on Oct 29 2010 - 08:30 AM, said:

Stutters sometimes happen related to sound card issues.  Try disabling the sound card in system > hardware> device manager and driving without sound

Yes as Bob says you should take a look at the sound card setup. I had the same micro stutters in GPL with a new high-spec PC & the culprit turned out to be the motherboard's onboard sound. I couldn't figure out a fix for it so in the end I disabled the onboard sound, then installed the ancient augidy 2 sound card out of my old PC & hey presto, GPL worked seamlessly after that.
Must be a pretty smart soundcard to know not to cause stutters when driving at 60fps. The problem sounds more like a background process which likes to run when cpu load is low. 60fps causes a higher cpu load, which might be enough to prevent the background process from running.

#9 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,731 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Oct 30 2010 - 04:25 AM

So a program like GPL power monger could fix it? :rolleyes:

Edited by Ginetto, Oct 30 2010 - 04:26 AM.


#10 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 30 2010 - 04:28 AM

I'm with Petteri here. Seems unlikely that the stutter don't happen with 60 FPS but with 36 FPS. And I assume that it happens without AI or only with AI?
But XP Sp3. Not many stuff that happens in the background. Only Indexing is using CPU low loads to start indexing. Or defragmentation programs like O&O defrag. Or a virus scan. But other then that 3 programs I can't imagine what should run with low CPU load?
:idunno:

#11 Jumi2

Jumi2

    Erzkanzler

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 386 posts
  • Gender:Male
  • Location:Wooooohooo
  • Interests:Sports, Guitars.
  • Sim interest:GPL

Posted Oct 30 2010 - 10:36 AM

Thanks for all the ideas! I will try around a bit more.

I will try with power monger, thats actually a good idea.
Can you guys confirm that running a tft is not the issue? I was using a crt before and never had such problems.

No it was all without AI, it happens worst when online with others people. Its hard to nail down since it is so random.

Edited by Jumi2, Oct 30 2010 - 10:36 AM.


#12 Frenchy

Frenchy

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 03 2010 - 06:07 AM

I have similar problems since I upgraded my video card. two of the worst things are chat (you can disable in game options but the 'soandso connected' still causes stutter), and the LQS meter (alt-m, sometimes it is hidden behind prib but if it is on it causes me major stutters). These would explain why you only get it in 36fps(online?) but not 60fps (offline?).

Good luck and pls keep me informed if you make any progress.

Oh, and I reckon BRR's outline fonts in prib 1.1.2.1 helped a bit too.

Cheers
David

#13 dbell84

dbell84

    Dan Gurney For President

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 920 posts
  • Gender:Male
  • Location:20 minutes from Road Atlanta
  • Interests:Whatever
  • Sim interest:GPL

Posted Nov 03 2010 - 06:49 AM

Hi Frenchy  :wave:

I'm curious, what is the video card to you put in and what was the card you replaced?

Also, good to see you here again.  It seems like I haven't seen you around for a while.

Dave

#14 Frenchy

Frenchy

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 03 2010 - 07:10 AM

View Postdbell84, on Nov 03 2010 - 06:49 AM, said:

Hi Frenchy  :wave:

I'm curious, what is the video card to you put in and what was the card you replaced?

Also, good to see you here again.  It seems like I haven't seen you around for a while.

Dave

Hi Dave

I've been lurking :) Check in most days but been a bit too busy to post (should be in bed now). Didn't really get time for the Gone Gold event this month especially since I haven't driven 69's for a while. (Did one lap in the 67 lotus and realised it was going to be very time consuming)

I replaced my nVidia9600GT with a 250GTX and in some ways performance is worse in GPL. mostly it runs fine but certain events seem to produce a noticable stutter. Especially those I outlined above but also running off track, and when I first drop in to the pits, it takes a few seconds to settle down. Mostly I upgraded for iRacing but haven't really noticed a big step-up there either although it is an improvement.

I am running an Intel Core2 Quad Q9300 (2.5GHz) with Vista32. I am using on-board sound but have always had perfect sound on this PC so I'm reluctant to try a new card.

Cya around
David

#15 M Needforspeed

M Needforspeed

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,464 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Nov 07 2010 - 02:19 AM

here a video where you can see huge stutterings displayed at full screen. I never experienced such bad thing. Now that i have seen it, I understand more Remco Hitman complaining about "slow motion " track side objects when playing on large LCD screen.certainly in such bad case,60 fps is the way to go.But if GPL is smooth as silk on a small screen, it should be on a very large. On a 5 meter diagonal VP, it can be very smooth, even with 36 Fps.  
Even with lower powered PC 8 years ago, I don't remembers Gplers getting such unbearable artifacts. The driver is still very fast !

  

  frenchy, you said the problem appeared with your new GFX card (GTX 250).But I had the opposite experience than yours.Seems that recent NVidia drivers with recent GFX(GTX 285)give very smooth results in GPL.But I changed completely the PC around the new GFX card.

  it is really boring that we get alls differents results for this game, with different hardware.

Edited by M Needforspeed, Nov 07 2010 - 02:42 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links