Jump to content


- - - - -

60 fps AI for testing


  • Please log in to reply
66 replies to this topic

#31 leon_90

leon_90

    Lorenzo Bandini

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,392 posts
  • Gender:Male
  • Location:Italy/Puglia
  • Interests:everything that has a Ferrari V12 inside
  • Sim interest:GPL and P&G

Posted Jun 17 2009 - 02:15 PM

ok, I've tried the patch with '67 version of the game in the circuits of Monaco and Monza 10k with standard ai from papyrus.
The ai works properly and marks right times, no more "banking-fobia"; indeed now the ai on Monza 10k seems to be faster than necessary but nothing that we cannot handle because are only max 2 seconds faster than normal in their times.I think that everything is alright now. If you need other checks, ask. I'll gladly help you. :D

Regards,
Leon

#32 Buk Nekkid

Buk Nekkid

    Jochen Rindt

  • Members
  • PipPipPip
  • 27 posts

Posted Jul 07 2009 - 10:25 PM

Thank-you for the AI 60FPS, going to give this a good thrashing on the weekend.

Cheers, Neil :)

#33 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jul 08 2009 - 01:48 AM

The 60fpsv2 patch is out, which allows driving with AI as well (see the first post in this topic for a link). Only the original 67 AI is expected to be somewhat driveable, since most mods change AI in a way which depends on 36 fps.

#34 Björn

Björn

    Mike Parkes

  • Members
  • PipPip
  • 12 posts

Posted Jul 08 2009 - 02:22 AM

Hi,
I managed to get the v2 running with the 65s and the 67s, but no luck with the 66mod. I get a CSD, i´when I hit the green button.
Furthermore GEM+ crashes if I choose the 66 carset and start GPL through GEM+ or end GEM+. (so when the gplc66 is created: GEM+ Fatal Error...).

Has anyone have a working gplc66.exe?

Attached Files



#35 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jul 08 2009 - 02:26 AM

View PostBjörn, on Jul 8 2009, 11:22 AM, said:

Hi,
I managed to get the v2 running with the 65s and the 67s, but no luck with the 66mod. I get a CSD, i´when I hit the green button.
Furthermore GEM+ crashes if I choose the 66 carset and start GPL through GEM+ or end GEM+. (so when the gplc66 is created: GEM+ Fatal Error...).

Has anyone have a working gplc66.exe?

Are you using the update 66mod and the 60fpsv2newmod patch? The error in the log means that the patch cannot be applied correctly. Since the same patch works for other mods, then the error is not a syntax error in the patch but incompatibility with other patches.

#36 Björn

Björn

    Mike Parkes

  • Members
  • PipPip
  • 12 posts

Posted Jul 08 2009 - 04:30 AM

Sorry, still had V1. Applied the patch and GEM+ still crashes, but the gplc66.exe works without CTD.
Still the AI doesn´t work well, the cars just shift up to 2nd gear and so are very slow.
Hope to see more improvement on this patch and thanks so far.

Björn

BTW: Look at my Member No and my posts No. Seems not to correspondent that well;)

#37 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jul 08 2009 - 04:38 AM

View PostBjörn, on Jul 8 2009, 01:30 PM, said:

Sorry, still had V1. Applied the patch and GEM+ still crashes, but the gplc66.exe works without CTD.

I have no idea what is causing it. The 60fps patches themselves work correctly in GEM+, so it must be a compatibility issue with something else you are using.

Quote

Still the AI doesn´t work well, the cars just shift up to 2nd gear and so are very slow.
Hope to see more improvement on this patch and thanks so far.

The cars are slow because mods modify AI in a way which is intended for 36 fps. I recommend using 60fps AI only with the original 67, unless you are willing to tweak the AI ini files (I don't know how much it can be improved that way).

#38 miklkit

miklkit

    airhead

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,137 posts
  • Gender:Male
  • Location:left coast, U.S.A.
  • Interests:GPL
  • Sim interest:GPL

Posted Nov 02 2009 - 05:39 PM

Ever since the mod patches have been installed, normally the only way to get 60fps ai has been to use the newmod ai.  

Recently I went to Clermont-Ferrand in the 66s.  Clicked the newmod button in GEM first.  Had a good race, but noticed that the ai sat the normal ride height.   :huh:   They generally drove much more realistically also.   ^_^   After the race I went back to GEM and found that I had accidentally clicked the 60fpsaiv1 button.   :o   This button had ceased to work a while back, so I'm confused again.  But in a good way!   :lol:  I really disliked the newmod ai and it's nice to be able to use the good ai again.   B)   I've tried them in all versions of GPL I have, and they work.  It is still a track by track thing as to how WELL they work, but they are still better than what we had before.  :)  

Is anyone else aware of this?  Can anyone else duplicate this?   :report:

#39 M Needforspeed

M Needforspeed

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,457 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Nov 23 2010 - 12:39 PM

View Postmiklkit, on Nov 02 2009 - 05:39 PM, said:

Ever since the mod patches have been installed, normally the only way to get 60fps ai has been to use the newmod ai.  

Recently I went to Clermont-Ferrand in the 66s.  Clicked the newmod button in GEM first.  Had a good race, but noticed that the ai sat the normal ride height.   :huh:   They generally drove much more realistically also.   ^_^   After the race I went back to GEM and found that I had accidentally clicked the 60fpsaiv1 button.   :o   This button had ceased to work a while back, so I'm confused again.  But in a good way!   :lol:  I really disliked the newmod ai and it's nice to be able to use the good ai again.   B)   I've tried them in all versions of GPL I have, and they work.  It is still a track by track thing as to how WELL they work, but they are still better than what we had before.  :)  

Is anyone else aware of this?  Can anyone else duplicate this?   :report:


Yes, we can !

at least I tried today, thks to this thread

#40 M Needforspeed

M Needforspeed

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,457 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Nov 23 2010 - 12:40 PM

View Postmiklkit, on Nov 02 2009 - 05:39 PM, said:

Ever since the mod patches have been installed, normally the only way to get 60fps ai has been to use the newmod ai.  

Recently I went to Clermont-Ferrand in the 66s.  Clicked the newmod button in GEM first.  Had a good race, but noticed that the ai sat the normal ride height.   :huh:   They generally drove much more realistically also.   ^_^   After the race I went back to GEM and found that I had accidentally clicked the 60fpsaiv1 button.   :o   This button had ceased to work a while back, so I'm confused again.  But in a good way!   :lol:  I really disliked the newmod ai and it's nice to be able to use the good ai again.   B)   I've tried them in all versions of GPL I have, and they work.  It is still a track by track thing as to how WELL they work, but they are still better than what we had before.  :)  

Is anyone else aware of this?  Can anyone else duplicate this?   :report:


Yes, we can !

at least I tried today, thks to this thread  

http://srmz.net/inde...t=0

Edited by M Needforspeed, Nov 23 2010 - 05:29 PM.


#41 M Needforspeed

M Needforspeed

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,457 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Nov 23 2010 - 05:22 PM

In fact, I tested on various Sport Car Mod Season.ini tracks, and it's not only possible but easy to adjust the AI speed.With the Fps60aiV1, it is rather a speed up process that 's needed.
  I got the fastest, Phil Hill, running in the 3.21.XX range at Le Mans, faster than Bruce Mc Laren practice real lap.And after a 24 laps long race with those beasts lapping in the 3.28 XX average :shock: , only 3 DNF, and 16 went to the chequered flag.
  Speeding up the AI doesn't seem to affect their global behaviour on the track.
  When they pass, they strangely do it fast, and that's the main bug, as well as suddenly changing their racing line on straights.But those are minors bugs, imo.
  And  perhaps corrective tweakings are possible.    
  
  That's rather good news.So post above has been edited.

Edited by M Needforspeed, Nov 23 2010 - 05:30 PM.


#42 Pedro

Pedro

    Pedro

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,346 posts
  • Gender:Male
  • Location:Hillegom - The Netherlands
  • Interests:Grand Prix Legends
    Scuba-diving
    Airplanes
    Money :-)
  • Sim interest:GPL

Posted Nov 24 2010 - 12:33 PM

So sorry I can't help it, but I just had to react:

of topic.

View PostM Needforspeed, on Nov 23 2010 - 12:40 PM, said:

Yes, we can !

YES WE CAN

on Topic.

#43 M Needforspeed

M Needforspeed

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,457 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Nov 28 2010 - 11:58 AM


   fps60aiV1 NEWS

here two track.inis where the GT Mod run nice.With the fps60aiV1

  Solitude track.ini.
  Tweaked Zandvoort track.ini.

Yesterday, I looked at the race at Solitude, with a full grid.The AI 's passes in many parts of the track, that is rather rare.An you have even AIs, which, after have been laped, go as far as 200 meters back, then  come back and sometimes pass the car who passed it ! I never noticed that in GPL.Looking them racing was simply a pleasure, with beautiful Thomas Lachaele add ons.
AI 's too are reliable

When I saw so good promising results, I installed some key lines of the Solitude track to the Zandvoort track.With the default track.ini, AI 's where desperately slow on the long straight.Now they go as fast as 270.But there a little slow on curve, to achieve real laps time .With a little further tweaking, all should be correct.
  Now, they run on correct laps time, pass at many places, and won 't crashes nor make mistake.I was the spectator of a very beautiful race, with dual fights between AIs !They passes on various part of Zandvoort track, including the hairpin, and after Tarzan.

I have witnessed only few pass at the end of the straight, but it is rather because the relative speed of each AI doesn t give enough room, as explained Border Reiver.


  To summarize, I wld even say that Sport Cars passes more often than AI's of any other GPL mods.And apart some weird move, globally they act more realistically.

  back up your track.inis first, and if you want to give them a go .Don 't try to change anything is the Gpl_ai_ini.
  

First is Solitude
2 is for Zandvoort

Attached Files


Edited by M Needforspeed, Nov 28 2010 - 12:00 PM.


#44 Rhambus

Rhambus

    Jo Siffert

  • Members
  • PipPipPip
  • 25 posts
  • Interests:Sim racing
  • Sim interest:GPL

Posted Jul 24 2011 - 01:08 AM

I did a few time accelerated races with the 60fps patch and like others have mentioned the AI is incredibly slow. At Monza, the best lap was something like 1:46, without the patch they were back to running around 1:27 again. I could probably spin out twice and still be riding on the fastest cars tail. I haven't personally tried to race against the AI myself, so I may try that a bit tomorrow. A wee bit tired to try to focus on racing right now. :D

Also, I noticed the spread across the grid seems to be excessive with the 60fps patch, at least from the races I tested. Most full length Grand Prix races seemed to end with up around a minute margin of victory, with typically only 1-2 cars being on the lead lap, where without the patch there were constantly 5-6 cars on the lead lap, with the margin of victory typically being anywhere between a few seconds to maybe 8-10 seconds except for at Monaco, but Monaco is a harsh track anyways, even for the AI. :D

Tomorrow I will try to get some more info to see if I can provide you with any information that would help polish the AI a little more. If we could get the AI issues ironed out this patch would be a blessing. :D

#45 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jul 24 2011 - 05:08 AM

View PostMistwaver, on Jul 24 2011 - 01:08 AM, said:

I did a few time accelerated races with the 60fps patch and like others have mentioned the AI is incredibly slow.

From the first post in this topic: "Note that AI is only expected to be somewhat driveable for the original 67 only."

Edited by brr, Jul 24 2011 - 05:09 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links