Jump to content


- - - - -

Drivers Head Turned 45 Degrees At Goodwood65?


  • Please log in to reply
2 replies to this topic

#1 Saiph

Saiph

    Driving 4 Team BDS #JC4PM

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,386 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. simulations, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Oct 16 2021 - 11:02 AM

Hi all,

I'm having a really odd problem which I've been investigating for the last few hours and I'm stumped.

I've been catching up with some of GPL's newer TotalRank tracks, driving the '71 Can-Am McLaren M8F to get some nice fast laptimes. I've recently done laps at Roswell (looks great!), B&Wwerk Collmberg-Rennen, Dundrod 1955 TT, Guaporé, Ain Diab, Alta Gracia 1998, and a few others.

However, when I reached Goodwood 1965 earlier today, when I went to the track, I suddenly found that my drivers' viewpoint was turned about 45 degrees to the left. I checked the "look left" and "look right" keys, and they correctly moved my view (further) to the left and to the right, so the keys weren't "stuck" in any way. I then left GPL, shut down GEM and restarted everything, and when I got back to the track the problem was still there.

I then tried a few other tracks, and the viewpoint there was correct. I then left GPL again, and repeated my tests using other mods like F2, GTs, original '67s, and they all behaved the same way - at Goodwood 1965, the view was turned left by 45 degrees, and at all other tracks the view was fine. This puzzled me even more, as I remember driving some test laps with the '67 Brabham and Lotus 49 back in April last year, when the track was first released, and there were no problems.

I then assumed that there might be something wrong with my Goodwood installation, so I moved all the files from "Goodwd65" to a backup directory, and re-ran the track installer. But the problem was still there.

I then started to experiment with settings for the "77E Head Movement V3.0" patch, in case a bad setting was causing the problem. The first thing I did was to open the original patch ZIP file and copy the original XML file into the "\GPLSecrets\Gem+\Options\" directory, and my "GPL Head Movement V3.0" directory where I installed the manager program. I then deleted GPLM71.EXE from the GPL directory, and restarted GPL. I first went to the new Monza67 track, and the viewpoint was correct, but the "Glance" feature was active, so as I drove the car my viewpoint was turning left and right. I left Monza, and then went straight to Goodwood65 without quitting GPL. At Goodwood, the view was also correct, but again the "Glance" feature was active.

I then quit out of GPL and GEM, and ran the Head Movement Manager program. Under the "Cockpit Viewpoint Movement" tab, I made sure that both head movement options were turned off, then I clicked on the "Save To Patch" button, and exited. I deleted GPLM71.EXE again, ran GEM, and went back to Monza67. This time the view was correct, and there was no head movement. However, when I left Monza and went directly to Goodwood65 again, the view was turned 45 degrees left again.

I then simply tried deactivating the Head Movement patch, and this seemed to fix the problem. Without the patch, all the tracks I tried and all the mods behaved as expected, with a normal viewpoint and no head movement. So the problem is connected somehow with the Head Movement patch. But I have been running the patch for a long time now, because I enjoy seeing the drivers' heads moving when I'm watching replays. So I'm puzzled as to why this problem has started today, and with only one track!

If there's anyone out there who can puzzle out what might be wrong, or who could give me some ideas for more tests I could try, please let me know.

EDIT: I should also mention the GPLShift patch, as this can configure controls to change the drivers' viewpoint. I realised that although I no longer use my broken steering wheel, I had left my base GPL.EXE patched. So I ran the patcher to get rid of GPLShift, and I found that this didn't make any difference.

Edited by Saiph, Oct 16 2021 - 11:35 AM.


#2 kuratko

kuratko

    Jackie Ickx

  • Members
  • Pip
  • 1 posts

Posted Oct 16 2021 - 02:15 PM

I observe exactly the same behavior as Saiph describes, at the goodwd65 track only and nowhere else, with multiple mods (55, 65, 66). I also found that switching to 'chasing' mod (F10) and then back to cockpit view fixes the problem (which is an acceptable workaround for me), but still, there is something specific probably for this track.

#3 Saiph

Saiph

    Driving 4 Team BDS #JC4PM

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,386 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. simulations, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Oct 16 2021 - 06:11 PM

View Postkuratko, on Oct 16 2021 - 02:15 PM, said:

.....switching to 'chasing' mod (F10) and then back to cockpit view fixes the problem......

Aha! Thanks for your reply kuratko! Yes, I just went back to Goodwood with the M8F, and as you found, pressing the 'F10' key twice resets the driver view. Such a simple fix! Why didn't I think of doing that?
:duh: :D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links