Jump to content


* * * * * 1 votes

Nigel's New Rasterizers


  • Please log in to reply
48 replies to this topic

#16 Steffen W - guest

Steffen W - guest
  • Guests

Posted Apr 02 2009 - 04:03 PM

View Postnpattinson, on Apr 2 2009, 02:55 AM, said:

View PostSteffen W, on Apr 1 2009, 09:56 AM, said:

when i set it to 32bit=0 it loads gpl but the main menu texts are blue and all other menu texts are missing entirely.
I don't know about the rest, but while I was developing the rasterizers my menu texts were coming out blue on a machine with an ATI card. I had a workaround for it, but discovered that when I upgraded the ATI drivers the problem went away, so I pulled the workaround out before the rasterizers were released. So new drivers may fix this problem, but I can't say for the others.

Nigel

Thanks Nigel,

since its not only the blueishness but also all other menu entries missung, it may well be a driver thing. mine are very old.

Steffen

#17 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Apr 03 2009 - 01:51 AM

Nigel,
may it be related to the new drivers ? Since 9.1 ATI has implemented full OpenGL 3.0 support. Maybe they have left out/crippled older openGL specifications ?

#18 npattinson - guest

npattinson - guest
  • Guests

Posted Apr 03 2009 - 04:43 AM

View PostBernd Nowak, on Apr 3 2009, 08:51 PM, said:

may it be related to the new drivers ? Since 9.1 ATI has implemented full OpenGL 3.0 support. Maybe they have left out/crippled older openGL specifications ?
I'd be surprised if it's to do with supporting OGL 3.0, I would imagine they aim for backward compatability. More likely random reintroduction of bugs. I do use a slightly obscure part of the OGL spec which happens to be very convenient, but may not get much testing.

Nigel

#19 aviator

aviator

    John Surtees

  • Members
  • PipPipPipPipPipPipPip
  • 38 posts
  • Sim interest:GPL

Posted Apr 26 2009 - 10:54 PM

I just switched to a new 26" monitor and installed the new rasterizers (OGL, 1900x1200). It is amazing how my feeling has changed now when i am driving! I feel so close to the wheels, it is like i can touch them, so close to the instruments, everything is now crystal clear. Thank you very much Nigel Pattinson for this. Excellent work!

#20 orville944

orville944

    Chris Irwin

  • Members
  • PipPip
  • 11 posts
  • Sim interest:GPL

Posted May 02 2009 - 09:38 AM

I really like the new rasterizers! Awesome work Nigel. It means I can run the later ATI drivers which think GPL is a 2D application unless in OpenGL mode... which used to look crappy... not any more!

Am I the only person who appreciates the new Fog option? A fog=4 at Spa adds a lovely feel to the circuit... maybe better simulating what those crazy drivers who raced in the rain might have seen. Makes me ponder... Could a different "type" of fog be used to appear like a semi-realistic rain?

Many many thanks! Mind-blowing achievements are still being released for this game! :D

#21 marko

marko

    Bruce McLaren

  • Members
  • PipPipPip
  • 23 posts
  • Sim interest:GPL

Posted Jul 30 2009 - 12:56 AM

This is a great addition to GPL!  Im running 1900x1200 smooth as glass all details solid 36fps.  Driving is much easier, even though I was gettin 36fps at a lower resolution before.  Now it feels like 60fps, really velvety smooth and it makes driving much easier -- nice and predictable -- no microstutters.  
Im running a nVidia 7950GT w/ 42.03 drivers 24" @ 1900x1200. OpenGL
Bravo!

Edited by marko, Jul 30 2009 - 12:57 AM.


#22 JethroTull

JethroTull

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 7 posts

Posted Aug 09 2009 - 11:36 AM

Hi, recently nVidia updated the W7 drivers (I suppose with the release of the RTM version) and GPL don't refresh the screen, I mean the titles/links are showed over the presentation screen, and the new windows are added on a transparent way, making all really confused and, of course, you can't drive.

I say this as an apportation.

Thanks for the drives, I had a lot of fun with this.

Sorry for my bad english.

#23 GaryG

GaryG

    Jackie Ickx

  • Members
  • Pip
  • 1 posts
  • Sim interest:P&G for GTR2

Posted Aug 15 2009 - 11:00 AM

Thanks for the update! I really never thought I would still be about to run and use GPL under Vista 64.

#24 Chalky

Chalky

    Guy Ligier

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jan 08 2010 - 04:45 PM

View PostPaul W., on Mar 18 2009, 08:26 PM, said:

I have a problem running them under ATI4870, I am not able to run the menu in d3d mode because it flickers (it was the same with the previous version)

That's true that the new OPENGL rasterizer got rid of horizontal lines in the sky but.. I don't know what makes my track go into a shade of blue? It happens at random....  every so often the track seems to be affected, this is how it looks

Posted Image
I'm running a ATI card and I had the same.
I'm running Pribluda on OpenGL v2 and I have a horrible blue tint on some textures. Rather than go back to the D3D and the flickering I started fiddling.
In GEM under the Rasteriser I changed my ZBuffer option from "Use ZBuffer" to "Run ZBuffer in a separate thread".
This has removed the blue tint.
So now I have OpenGL and Pribluda without any flickering.

#25 Whizkid

Whizkid

    Whizkid

  • Members
  • PipPip
  • 17 posts
  • Gender:Male
  • Location:Citrus Hts. Ca. USA
  • Interests:Grand Prix Legends,GTL,IL-2,ArmA2OA,I44
  • Sim interest:GPL

Posted Feb 04 2010 - 09:22 PM

Greets all! I'm having a desperate time trying to install Nigels new V-2s to use with Pribluda. I just can't figure out what his Read-me is telling me to do. You've all read it,and he talks about "You'll need to comment out your current options (with semicolons) and substitute these lines". What lines, and what do I replace? Then he says, "To configure the rasterizers, only change the second, 'RasterV2' section". Sorry, but I can't figure out that either. Maybe it's because I'm really a dummy with the PC and things are written for smart people! Anyway, if someone could show it in pictures for me that would help, I think. Thanks.

Edited by Whizkid, Feb 04 2010 - 09:23 PM.


#26 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Feb 04 2010 - 11:07 PM

View PostWhizkid, on Feb 04 2010 - 09:22 PM, said:

Greets all! I'm having a desperate time trying to install Nigels new V-2s to use with Pribluda. I just can't figure out what his Read-me is telling me to do. You've all read it,and he talks about "You'll need to comment out your current options (with semicolons) and substitute these lines". What lines, and what do I replace? Then he says, "To configure the rasterizers, only change the second, 'RasterV2' section". Sorry, but I can't figure out that either. Maybe it's because I'm really a dummy with the PC and things are written for smart people! Anyway, if someone could show it in pictures for me that would help, I think. Thanks.

Currently available Pribluda does not work with the DirectX V2 rasteriser. By patching Pribluda, it should work with the OpenGL V2 rasteriser.

#27 Whizkid

Whizkid

    Whizkid

  • Members
  • PipPip
  • 17 posts
  • Gender:Male
  • Location:Citrus Hts. Ca. USA
  • Interests:Grand Prix Legends,GTL,IL-2,ArmA2OA,I44
  • Sim interest:GPL

Posted Feb 05 2010 - 12:23 PM

Currently available Pribluda does not work with the DirectX V2 rasteriser. By patching Pribluda, it should work with the OpenGL V2 rasteriser.
[/quote]
Thanks for the reply, brr. Could you re-upload that patch here, as the original one that I have picked up a Trojan virus and is unusable. I had to re-install all of GPL because of it! GRRRRRRRR!

#28 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Feb 05 2010 - 12:30 PM

View PostWhizkid, on Feb 05 2010 - 12:23 PM, said:

Thanks for the reply, brr. Could you re-upload that patch here, as the original one that I have picked up a Trojan virus and is unusable. I had to re-install all of GPL because of it! GRRRRRRRR!

Its very likely a false positive:

http://virusscan.jot...761b759dcae3ed7

#29 Whizkid

Whizkid

    Whizkid

  • Members
  • PipPip
  • 17 posts
  • Gender:Male
  • Location:Citrus Hts. Ca. USA
  • Interests:Grand Prix Legends,GTL,IL-2,ArmA2OA,I44
  • Sim interest:GPL

Posted Feb 05 2010 - 01:21 PM

View Postbrr, on Feb 05 2010 - 12:30 PM, said:

View PostWhizkid, on Feb 05 2010 - 12:23 PM, said:

Thanks for the reply, brr. Could you re-upload that patch here, as the original one that I have picked up a Trojan virus and is unusable. I had to re-install all of GPL because of it! GRRRRRRRR!

Its very likely a false positive:

http://virusscan.jot...761b759dcae3ed7
Thanks so much, brr. That's an excellent tool which I didn't know existed. Only two out of the twenty scanners reported a Trojan, so I think you're correct....false-positive. I'll D/L your patch again and use it.

#30 dangermouse

dangermouse

    The mobile chicane

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 5,955 posts
  • Gender:Male
  • Location:SRMZ/GPLR London, UK
  • Interests:Errrrrr, GPL? :-)
    Music , computing, hi-fi, motor racing
  • Sim interest:GPL and P&G

Posted Feb 05 2010 - 02:53 PM

View PostWhizkid, on Feb 05 2010 - 01:21 PM, said:

View Postbrr, on Feb 05 2010 - 12:30 PM, said:

View PostWhizkid, on Feb 05 2010 - 12:23 PM, said:

Thanks for the reply, brr. Could you re-upload that patch here, as the original one that I have picked up a Trojan virus and is unusable. I had to re-install all of GPL because of it! GRRRRRRRR!

Its very likely a false positive:

http://virusscan.jot...761b759dcae3ed7
Thanks so much, brr. That's an excellent tool which I didn't know existed. Only two out of the twenty scanners reported a Trojan, so I think you're correct....false-positive. I'll D/L your patch again and use it.

I was going to say you were using AVG but I see that on brr's test it didn't show AVG as causing a problem. Which antivirus are you using?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links