Jump to content


Legends Of Gpl Mod Online Tests


  • Please log in to reply
33 replies to this topic

#21 paul skingley

paul skingley

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 606 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 30 2018 - 09:23 AM

Thanks for the work you do for us.


:thumbup:

#22 Roo

Roo

    Jim Clark student

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 321 posts
  • Gender:Male
  • Location:France 77
  • Interests:climbing
  • Sim interest:GPL

Posted Oct 30 2018 - 11:29 AM

awesome work guys, merci :thumbup:

#23 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,470 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted Oct 31 2018 - 06:34 AM

Thank you Lou and all involved for fixing the iGOR >7 car slots bug!

LoG works fine now. :up:
Also tested with 69 Extra mod (69x).


Only the Legends of GPL mod (LoG) 1967 Brabham BT24 still gives CTDs when you exit the car via ESC (on all tracks), but that is not iGOR/ server related.
Lee is it possible to fix?
I also noticed a graphics bug with the 1971 CanAm McLaren M8F: When you push the gas peddal the right mirror image flips. When you lift the gas peddal it is fine. But it is only in the right mirror of the 1971 CanAm McLaren M8F, the left mirror is fine. I am using the default FoV. Another GPLRACER racer also has this bug, so it`s not just me. Lee any ideas? :)

Edited by Stefan Roess, Oct 31 2018 - 06:35 AM.


#24 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,711 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 31 2018 - 02:13 PM

Good to hear that the IGOR bug is fixed.  Thanks again to Lou and team for this.  :)

I can't duplicate the BT24 CTD offline.  Online, it CTD into a section of code for the rasterizer when using the d3d7v1 rasterizer.  I can't debug using any other rasterizer so can't determine where the CTD occurs, but suspect it's in the rasterizer code too.

The only difference that I'm aware of between on and offline racing is the different car skins.  Maybe it's a specific numbered car skin that causes the CTD?  Stefan, do you know which number skin is being used online when the crash occurs?

I've seen that inverted mirror on the M8F too and don't have a fix.

Edited by Lee200, Oct 31 2018 - 02:14 PM.


#25 Saiph

Saiph

    Still driving 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,112 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. simulations, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Oct 31 2018 - 03:22 PM

View PostStefan Roess, on Oct 31 2018 - 06:34 AM, said:

......
I also noticed a graphics bug with the 1971 CanAm McLaren M8F: When you push the gas peddal the right mirror image flips. When you lift the gas peddal it is fine. But it is only in the right mirror of the 1971 CanAm McLaren M8F, the left mirror is fine......

So when you press the throttle, the mirror is affected?? :o :huh: Sounds like the witches are out for Halloween!

#26 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,470 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted Nov 02 2018 - 08:04 AM

View PostLee200, on Oct 31 2018 - 02:13 PM, said:

The only difference that I'm aware of between on and offline racing is the different car skins.  Maybe it's a specific numbered car skin that causes the CTD?  Stefan, do you know which number skin is being used online when the crash occurs?

Not yet. I will check.

Btw the Brabham BT24 of the 1967 Extra (67x) full mod works online without CTDs.


View PostLee200, on Oct 31 2018 - 02:13 PM, said:

I've seen that inverted mirror on the M8F too and don't have a fix.

I guess the 1971 CanAm McLaren M8F of the full mod does not have this error. At least I have never noticed it.

Did we ever have a similar error like this with any mod during beta testing?

Edited by Stefan Roess, Nov 02 2018 - 08:04 AM.


#27 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,711 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 02 2018 - 08:41 AM

I had to move the BT24 from its original slot of 0 to slot 4 and apparently screwed up something.  As you know, moving a car's slot is not a trivial task and involves of a lot of file twiddling.  What is troubling is that the BT24 works OK offline, but not online so it's difficult to troubleshoot.

Even though the 1967 Extra mod works OK, that doesn't really help for the LoG mod.

#28 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 3,183 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Nov 02 2018 - 10:32 AM

I made a proper forum for the MOD so all its discussion can be easily found.

#29 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,711 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 02 2018 - 02:47 PM

Thanks Ginetto.   A proper mod deserves a proper forum.  :)

#30 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,470 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted Nov 05 2018 - 06:03 AM

Ginetto, thx for the LoG forum.


@Lee, we have found another LoG bug.
When I limit my server to just one car for a spec race and a client joins the server without picking that only available car he will join with the car that he used for his last join. Actually, you shouldn`t be able to join at all if you don`t pick a car.

I don`t know if this is also possible with the full mods as we rarely do spec races.

Edited by Stefan Roess, Nov 05 2018 - 06:04 AM.


#31 GrandPrixYannick

GrandPrixYannick

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 956 posts
  • Gender:Male
  • Location:Netherlands
  • Interests:Check out my channel for some nice GPL content :)
  • Sim interest:GPL

Posted Nov 05 2018 - 08:20 AM

View PostStefan Roess, on Nov 05 2018 - 06:03 AM, said:

Ginetto, thx for the LoG forum.


@Lee, we have found another LoG bug.
When I limit my server to just one car for a spec race and a client joins the server without picking that only available car he will join with the car that he used for his last join. Actually, you shouldn`t be able to join at all if you don`t pick a car.

I don`t know if this is also possible with the full mods as we rarely do spec races.
I think that this is a bug related to iGOR, not to the LoG mod.

When you set a server, make it a spec race, joining players tick the only available car and join.

When you exit a server, iGOR will still think you stick with that same car. So when you want to re-enter the server and the spec car has changed,
the name of that car is crossed, yet still is the car ticked on.
So if you enter without changing it to the new spec car, you will still be in old spec car regardless.

#32 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,711 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 05 2018 - 10:31 AM

I agree that it's probably an IGOR bug...not LoG.

#33 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,184 posts
  • Gender:Male
  • Location:near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Nov 05 2018 - 02:34 PM

View PostLee200, on Nov 05 2018 - 10:31 AM, said:

I agree that it's probably an IGOR bug...not LoG.
I confirm, this works with every mod!

#34 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,470 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted Nov 06 2018 - 02:28 AM

View PostCookie, on Nov 05 2018 - 02:34 PM, said:

View PostLee200, on Nov 05 2018 - 10:31 AM, said:

I agree that it's probably an IGOR bug...not LoG.
I confirm, this works with every mod!

Interesting. I didn`t know that.
Thx for the feedback Yannick, Lee and Cockie.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Sim Racing Links