Jump to content


- - - - -

Logitech G29 Driving Force


  • Please log in to reply
18 replies to this topic

#1 Hondaman

Hondaman

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 56 posts
  • Gender:Male
  • Sim interest:GPL

Posted Dec 30 2016 - 04:12 PM

Hi,

I know there's a thread for the G920 but the G29 is a different model, made for PS3/PS4/PC.

Fist off, there's a switch on top of it that lets you select PS3 or PS4.
On the website, they tell you to set it for PS4 for PC, but it doesn't work for me. I had to select PS3 for it to work on PC.

You also have to download and install "Logitech Gaming Software" to control it, which is incomplete and has bugs, in my opinion.

Quote

I got it to work with GPL but my main problem right now is I'm a little short of speed.
For example, at Albi'67 in the F2Mod, I'm about 8-10 km/h short on the straight.
Similar lack of speed at Monza with the 69x mod.

Of course, I always calibrate the wheel and pedals in GPL and I do get max RPM and over, but there's still some speed missing.

Any ideas?[EDIT] Problem solved - maybe a piece of foam was obstructing the throttle

------
A good piece af advice from Bob Simpson: Try using DXTweak2 at http://www.force-dynamics.com/dl
http://forums.speedg...68

Edited by Hondaman, Dec 31 2016 - 02:52 PM.


#2 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,967 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Dec 30 2016 - 06:06 PM

If you're getting max RPM, then it doesn't sound like you have a problem with the wheel or pedals. Are you sure you're selecting the full race car before you go on the track, and not one of the trainer cars?

#3 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Dec 31 2016 - 04:30 AM

My trusty G27 packed up a few weeks ago and I've got a G29 arriving sometime today hopefully.

I'll let you know how I get on with it :)

#4 MrDarkSide

MrDarkSide

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 121 posts
  • Gender:Male
  • Interests:-
  • Sim interest:GPL

Posted Dec 31 2016 - 09:54 AM

I use a G29. I got it to work on the PS4 setting by installing FairShift. Now it works flawlessly except that the driver's arm doesn't move when I shift (which I can live with).

#5 Hondaman

Hondaman

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 56 posts
  • Gender:Male
  • Sim interest:GPL

Posted Dec 31 2016 - 02:45 PM

View PostSaiph, on Dec 30 2016 - 06:06 PM, said:

If you're getting max RPM, then it doesn't sound like you have a problem with the wheel or pedals. Are you sure you're selecting the full race car before you go on the track, and not one of the trainer cars?
Thanks but I made sure of that.
I did an online race last night and was able to get full speed.
Could be that, unbeknownst to me, some piece of foam was obstructing the throttle, I'm ashamed to say.

#6 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Jan 01 2017 - 02:47 AM

Glad to hear it works, the shifter arrived yesterday but it seems my wheel and pedals are due today :)

#7 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Jan 03 2017 - 12:00 PM

Well it's finally arrived. Seems to work OK apart from GPLShift..... will have to try Fairshift.

I finally found out how to set rotation to 550 degrees, but I can't find out how to turn off wheel damping... it's like driving through treacle and loses most of GPL's pretty decent FFB :(

Any ideas?

#8 Hondaman

Hondaman

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 56 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jan 03 2017 - 02:22 PM

View PostFat Rich, on Jan 03 2017 - 12:00 PM, said:

Well it's finally arrived. Seems to work OK apart from GPLShift..... will have to try Fairshift.

I finally found out how to set rotation to 550 degrees, but I can't find out how to turn off wheel damping... it's like driving through treacle and loses most of GPL's pretty decent FFB :(

Any ideas?
Try allowing game to set FFB (in settings, G29 tab) and try different FFB values in GPL CORE.INI.

Edited by Hondaman, Jan 03 2017 - 02:22 PM.


#9 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Jan 03 2017 - 05:08 PM

Thanks for the reply, had a quick go but it didn't seem to help.

Will try with other mods tomorrow and see if I can improve it.... the old G27 felt so much better.

Why do manufacturers have to remove useful features when they update their software? :(

Edited by Fat Rich, Jan 03 2017 - 05:08 PM.


#10 Hondaman

Hondaman

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 56 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jan 03 2017 - 05:30 PM

I experimented with different values today at Grenzlandring with the CA71 cars, a track where you go flat out and only turn slightly left.
That was a conclusive test.

I'm still trying other values but I got a nice feel with this:
[ Joy ]
allow_force_feedback = 1					 ; Use FF if device has it 0 = No * 1 = Yes
force_feedback_damping = 60.0000000		 ; force feedback damping coefficient - Default = 40.0
force_feedback_latency = 0.004000		 ; force feedback latency (secs) - Default = 0.085 0.0040000
max_steering_torque = 600.000000			 ; steering torque in N*in giving max device force - Default = 225.0
		 ;FFB steer vibe freq mult = 0.2000000

PS: higher values for torque and damping should offer less steering resistance.

Edited by Hondaman, Jan 03 2017 - 05:34 PM.


#11 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Jan 06 2017 - 03:11 AM

I've fiddled with the values some more, on some mods it increases the forces but it doesn't get rid of the numbness and treacley feeling :(

My old G27 felt like this until I turned off damping in the old Logitech profiler, then it came alive and felt fantastic. If only there was still an option to do that with the new G29 software.

I think I'm going to have to try to fix my G27 or source a replacement, GPL is no fun with the G29. Which is a shame, on more modern sims the wheel is pretty good.... the brake pedal feels better and it's nice having more buttons on the wheel.

Thanks for your help, Hondaman :)

Edited by Fat Rich, Jan 06 2017 - 04:44 AM.


#12 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 859 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted Jan 06 2017 - 06:43 AM

Try to exit Logitech profiler and change settings through Control Panel -> Game devices.

#13 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Jan 06 2017 - 07:53 AM

I'm running Windows 10 so finding things isn't that easy :harumph:

In Control Panel > Connected Devices it only gives an option to remove the device....

In Control Panel > Hardware and Sound > Devices and Printers > G29 Driving Force Racing Wheel > Game Controller Settings there are options to calibrate but nothing for damping.....

In Device Manager there are no options to change wheel settings, only system stuff for drivers.

I'm struggling to find my way round Windows 10, it's possible that there's some other setting hidden away somewhere that I can't find yet. It seems to like hiding things, and generally finding new and interesting ways of hampering me doing the things I need to do!

#14 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,377 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Jan 06 2017 - 10:49 AM

View PostFat Rich, on Jan 06 2017 - 07:53 AM, said:

In Control Panel > Hardware and Sound > Devices and Printers > G29 Driving Force Racing Wheel > Game Controller Settings there are options to calibrate but nothing for damping.....

In Device Manager there are no options to change wheel settings, only system stuff for drivers.


At this point you don't see this?

Attached Files


Edited by Bob Simpson, Jan 06 2017 - 10:50 AM.


#15 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 774 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Jan 06 2017 - 12:14 PM

Nope, I had all those lovely settings on my G27 software but the G29 uses new Logitech software and drivers.

The old Logitech G25 and G25 software and drivers don't recognise the G29 :(

Edited by Fat Rich, Jan 06 2017 - 12:15 PM.


#16 mcmirande

mcmirande

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 949 posts
  • Gender:Male
  • Location:Tucum├ín, Argentina
  • Sim interest:GPL

Posted Dec 08 2018 - 11:14 AM

I think it's time to release an "unfairshift", to properly use the G29 shifter and any other H shifter under Linux for GPL...

It's a shame gplshift don't work for both cases...

Marcos

#17 jonboy99

jonboy99

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Sim interest:GPL

Posted Mar 19 2019 - 03:15 PM

Hi all,
First time poster here so apologies if everyone knows about this fix now, but there is a direct registry edit option to allow disabling the damper etc options that the logitech software for the G29 does not have. I found them here:
http://forum.project...Gaming-Software

They allowed me to get my G29 feeling perfect like my old MOMO wheel in GPL.

However I cannot get fairshift working, despite trying all settings. Bob Simpson, I am understanding correctly from your post that you have a G29 and have it working properly with fairshift?

Thanks
Jon

Edited by jonboy99, Mar 19 2019 - 03:15 PM.


#18 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,377 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Mar 19 2019 - 03:33 PM

Thanks for the info Jon. I have a G25 wheel, but I don't use Fairshift.

Edited by Bob Simpson, Mar 19 2019 - 03:34 PM.


#19 jonboy99

jonboy99

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Sim interest:GPL

Posted Mar 20 2019 - 04:27 PM

Thanks Bob. i've actually got fairshift working properly with fairshift, as long as i don't use the clutch switch option. This seems to be a g29 issue. The gear won't go in until the clutch is partially released, meaning it goes in with a jerk and upsets the car. Not sure if the reversed axis on the clutch pedal is the cause. With the clutch switch box unchecked in fairshift, it behaves completely normally.

GPLshift would be a great alternative, but it seems it supports the g27 and g25 logi wheels only, not the G29 - the shifter just does nothing despite trying all the different ini file options. Oh well, I can live with fairshift without the clutch switch option. Good to be on GPL again after 9 years away when I left my old momo wheel in another country! Very impressed with this g29 for the price, despite the frequent criticism it gets in reviews.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links