Jump to content


- - - - -

Windows 10 High Dpi Display Issue


  • Please log in to reply
6 replies to this topic

#1 Sad Nation

Sad Nation

    Mike Parkes

  • Members
  • PipPip
  • 13 posts
  • Interests:Racing
  • Sim interest:GPL

Posted May 19 2017 - 08:43 AM

I have just found an issue with Windows 10 if you have the high dpi scaling turned on. As I have a 4k display (3840 x 2160) I have the display turned on to 175% scaling. Unfortunately this leads to the driving screen in GPL being offset. If I turn the scaling back to 100% it works okay.

Is there any work around for this or do I just resign myself to turning the scaling back to 100% whenever I want to play GPL (the only game that does this and yes I know it dates back to 1997 before screen scaling was even thought about!)?

Thanks in advance

Sad Nation

#2 gliebzeit

gliebzeit

    Targa Fan

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,577 posts
  • Gender:Male
  • Location:Florida - USA
  • Interests:Old guy stuff...
  • Sim interest:GPL

Posted May 19 2017 - 10:00 AM

I'm afraid that your issue appears to be with the settings within the TV monitor.

Edited by gliebzeit, May 20 2017 - 09:02 AM.


#3 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted May 19 2017 - 03:09 PM

View PostSad Nation, on May 19 2017 - 08:43 AM, said:

I have just found an issue with Windows 10 if you have the high dpi scaling turned on. As I have a 4k display (3840 x 2160) I have the display turned on to 175% scaling. Unfortunately this leads to the driving screen in GPL being offset. If I turn the scaling back to 100% it works okay.

Is there any work around for this or do I just resign myself to turning the scaling back to 100% whenever I want to play GPL (the only game that does this and yes I know it dates back to 1997 before screen scaling was even thought about!)?

Thanks in advance

Sad Nation

Great job finding the setting. Try right click on the exe Properties>Compatibility>Tick "Disable display scaling on high DPI settings" for a possible automatic change of the scaling.

#4 Sad Nation

Sad Nation

    Mike Parkes

  • Members
  • PipPip
  • 13 posts
  • Interests:Racing
  • Sim interest:GPL

Posted May 20 2017 - 04:58 AM

Duh, why didn't I think of that!

Thanks, I will give it a go when I get home!

#5 M Needforspeed

M Needforspeed

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,447 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted May 20 2017 - 07:34 AM

do someone knows if your problem is related to W10 , or can we expect the same using Win 7 with a 4K screen?

#6 wolle3

wolle3

    Ludovico Scarfiotti

  • Supporter
  • PipPip
  • 7 posts
  • Interests:Simracing
  • Sim interest:GPL

Posted May 20 2017 - 07:59 AM

That works. Great to have a solution for the wrong POV i had since my UHD Screen. Have scaled back to 100% too, and Bingo, thats the trick!!

Thanks a lot Sad or this hint!

Wolfgang

#7 Sad Nation

Sad Nation

    Mike Parkes

  • Members
  • PipPip
  • 13 posts
  • Interests:Racing
  • Sim interest:GPL

Posted May 20 2017 - 08:22 AM

Yeah tested it a minute ago in Gem and it works!

In Windows 10 Creators Update (the latest one) it is a bit different as they have improved the scaling method. In the Compatibility tab of the exe, just tick the Override high dpi Scaling Behaviour and choose Scaling performed by Application.

If you are using Gem and any mods, do this for the exe's that your mod uses i.e. gpl69.exe for the 69 mod.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Sim Racing Links