Jump to content


- - - - -

Crash With Certain Mods


  • Please log in to reply
30 replies to this topic

#21 Brocky05

Brocky05

    King of the Mountain

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Location:The Long And Winding Road
  • Interests:I'm Way Too Addicted to GPL For Anything Else
  • Sim interest:GPL

Posted May 18 2020 - 10:32 PM

did you install gem GPL and mods with administrator rights

have you checked your anti virus is not blocking mod exe files

have you tried compatibility mode

if not try all the above

if you have then we are a few more steps closer to fixing your problem

#22 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,629 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted May 19 2020 - 02:53 AM

Edit:
Compyableaphid52 in post #23 you talk about different systems that you have tried to get GPL and mods to work. But currently you are on Windows 8, aren`t you?

Compyableaphid52 make a backup / copy of your sounds folder before you change anything, to be able to go back just in case something goes wrong.

If missing or corrupt sound files is not the problem.

AntiVirus also comes into my mind.
Is any AntiVirus blocking the GPL mod.exe (on the other hand if AntiVirus should block you shouldn`t be able to start GPL at all)?

It could also be graphics card settings related.
Are you using OpenGL v2 or D3D v2? Try the other rasterizer in GEM+.
Change your AA and AF settings in your graphics card settings. What works for one mod might not work for the other mod.
Have you tried another track to test? Which track does crash? In post #23  you write custom tracks work, which do you mean? The original Papy tracks?

I assume you have tried these steps for a fresh installation?
http://www.gplworld....tallation-guide

Edited by Stefan Roess, May 19 2020 - 03:03 AM.


#23 jgf

jgf

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 976 posts
  • Gender:Male
  • Location:Columbus, OH
  • Sim interest:GPL and P&G

Posted May 19 2020 - 06:14 AM

Also try disabling DEP temporarily and see if it is the culprit (it will flag any edited exe as possibly malicious and block it from running).

#24 M Needforspeed

M Needforspeed

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,819 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted May 19 2020 - 12:27 PM

As Lee title is all about running GPL on Windows 10,it can covers differents hardware.


here a few cents on my recent install  process on Win 10  FOR A DESKTOP PC ( config detailed on my profile )

Why using an installer ? it isn't what I did, as I had already a running GPL on my Win 7 older PC.Advantage is that I have immediatly an image of GPL as I use it, and don't have to go for options checking ect....

1 ) installed the papyrus original  GPL CD Rom contents on the usual C/ Sierra/ GPL path , sharing the same partition with Windows 10.

2)  I did a copy /paste of  all the GPL folder contents ( around 30 Gb) from my previous PC on the new basic GPL install at step 1, from a simple USB memory device.

3) Installed GEM ( GPL secrets directory) on the roots C:/SSD 500 Go drive sharing the same partition than Win 10.

4)Pointed GEM to the Gpl.exe

5) launched GEM

6) Make Mods / carsets active in GEM


.... and that's all .Everything  was displaying correctly in GEM, and I cld use all GPL Mods/ carsets/ options features as on my previous install.No bugs when launching GPL, whatever carset/ track I tried.pribluda ok.

Compared with some problems reported here,i didn't experienced a conflict between the GEM files already installed on my older install, and the new GEM installed .It is only luck,maybe.

windows defender was active  during all the install process, I didn't close any Win 10  running on startup program launched by default during the installation process.

Easy as can be .... Changing OS together with recent hardware components isn't forcibly a problem for the old Great Game that is GPL.

Edited by M Needforspeed, May 19 2020 - 01:50 PM.


#25 Compyableaphid52

Compyableaphid52

    Mike Spence

  • Members
  • PipPipPipPip
  • 31 posts
  • Interests:historic rally
  • Sim interest:GPL

Posted May 19 2020 - 01:25 PM

So, I got the 1965 mod working fine, i just said screw it and downloaded a different iso online, and did a reinstall, somehow it works now, i have no more time to try mods as i have to work in a half hour, but late tonight i will try some others like Can Am 66 and give updates on how it works or doesnt work! This is progress ive not once made before friends, I am very excited to race! -  Oh and i also updated my nvidia drivers to latest, which may or may not have had an effect with this

Edited by Compyableaphid52, May 19 2020 - 01:27 PM.


#26 M Needforspeed

M Needforspeed

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,819 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted May 19 2020 - 01:39 PM

an info I picked from various hardware sites : it ain't anymore useful to install the game on a different partition  than Win 10 OS, when you use the latest  SSDs sold on the market

Edited by M Needforspeed, May 19 2020 - 01:42 PM.


#27 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,629 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted May 19 2020 - 01:50 PM

View PostCompyableaphid52, on May 19 2020 - 01:25 PM, said:

So, I got the 1965 mod working fine, i just said screw it and downloaded a different iso online, and did a reinstall, somehow it works now, i have no more time to try mods as i have to work in a half hour, but late tonight i will try some others like Can Am 66 and give updates on how it works or doesnt work! This is progress ive not once made before friends, I am very excited to race! -  Oh and i also updated my nvidia drivers to latest, which may or may not have had an effect with this

Did you really download an ISO file? Of the 65 mod?!
At least good news that the 65 mod is now working.
I didn`t mention updating to the latest graphics card drivers, I thought that was clear. ;)

Edited by Stefan Roess, May 20 2020 - 03:53 AM.


#28 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,065 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted May 19 2020 - 03:14 PM

Since you cant have too many sound files, you can check against a list of a working install and add those missing in yours.

I've attached a list of my sound folder files if you want to give it a try. It's pretty much every mod bar the 67 and the 68 mod. I suggest going to your GPL\sound folder, marking all files, SHIFT+rightclick and select copy as path from the context menu for getting your own list.

Attached Files



#29 Compyableaphid52

Compyableaphid52

    Mike Spence

  • Members
  • PipPipPipPip
  • 31 posts
  • Interests:historic rally
  • Sim interest:GPL

Posted May 24 2020 - 08:17 PM

Just an update, i have all the mods that i want running, along with all the tracks for said mods working fine, all mods work on different seasons, ect., I just want to thank everyone for the help, and apologize for the spam, either way, im up and running, so im gonna go play through the entire can am 71 season and be happy. Cheers all!

#30 Brocky05

Brocky05

    King of the Mountain

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Location:The Long And Winding Road
  • Interests:I'm Way Too Addicted to GPL For Anything Else
  • Sim interest:GPL

Posted May 24 2020 - 09:04 PM

sweeeeeeeeeet

#31 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,065 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted May 25 2020 - 02:57 PM

Great to hear. For posterity's sake what was the cause of your troubles and how did you fix it?

Edited by Michkov, May 25 2020 - 04:59 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links