Jump to content


- - - - -

Screen Problems

screen resolution gpl grand prix legends problems core rasterizer d3d opengl

  • Please log in to reply
30 replies to this topic

#21 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,446 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Nov 07 2015 - 09:08 PM

I wonder if the monitor is showing the GPL menus which are at 640x480 and not adjusting to the new resolution.

#22 syd_drake

syd_drake

    Bruce McLaren

  • Members
  • PipPipPip
  • 23 posts
  • Gender:Male
  • Interests:GPL, Assetto Corsa
  • Sim interest:GPL

Posted Nov 08 2015 - 03:05 AM

Yes, actually, that's how it's feeling. Menus are definitely at 640x480, and that is the only resolution which is showing full screen when on track.

#23 John Woods

John Woods

    Be Somebody

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,722 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Nov 08 2015 - 06:18 AM

Been following along with this strange issue...but similar to past experiences with monitors.

Two cent wild guesses:

1. While in car, open monitor's config dialog and play with options?
2. Contact Dell support?
3. Dump Win10 for Dell supported OS?
4. If possible, try different monitor cable? (PC or HDMI, although on my rig using HDMI with GPL got no sound).

Interesting HDMI thread: http://srmz.net/inde...636

Edited by John Woods, Nov 08 2015 - 10:38 AM.


#24 mysterion

mysterion

    Chris Irwin

  • Members
  • PipPip
  • 9 posts

Posted Jun 29 2017 - 03:48 PM

I've got this exact same issue trying to run GPL at 2736 x 1824 (surface pro 4) As soon as I go in car the view is cut to small portion of the frame; as if the menu resolution is being carried through to the game. I note that my default resolution did not appear as an option until I added it manually via GEM.

Has anyone else encountered this issue since?

#25 geoslake

geoslake

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Interests:life
  • Sim interest:Nascar

Posted Feb 18 2020 - 09:43 AM

Hi guys. I'm having the same issue with my gpl install on my hades canyon with amd gpu.
With the d3d renderer it doesn't show me anything beside the menus (when I wanna start a race it's stuck at showing me the menu but I get the proper engine / race sounds).
With open gl it's okay in lower resolutions, but it's ugly of course.
If I select 1080p I can only see a portion of the screen.
Same with the latest 2020 demo.

Any idea? Cheers

#26 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,067 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted Feb 18 2020 - 03:33 PM

There is an option called direct mirror rendering in the menu that pops up when you click on the rasterizer button in GEM. Tick it and it should show the full screen.

Alternatively you may have an extra video cable plugged into your machine, even without anything connected to it it may mess with your GPU. Unplug it PC side and it may solve the issue.

#27 Jordi

Jordi

    Jackie Ickx

  • Members
  • Pip
  • 1 posts
  • Interests:Sim f1<br />
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted Apr 16 2020 - 12:26 PM

I had the same problem. The solution in my case, was just to change the screen  scale to from 125% to 100%... simple as that after testing a lot of settings!
It works great at 2500x1400 in a benq screen with Nvidia Quadro.

#28 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,810 posts
  • Gender:Male
  • Interests:Football
  • Sim interest:GPL

Posted Apr 16 2020 - 01:02 PM

Look here:

http://srmz.net/inde...23

Pay particular attention to item F.

#29 skx

skx

    Jack Brabham

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 50 posts
  • Gender:Male
  • Interests:mecanics
  • Sim interest:GPL

Posted Apr 17 2020 - 12:43 PM

Does anyone know how to use D3D in 2560x1440 ?
Thanks

#30 tikfas

tikfas

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 154 posts

Posted May 03 2020 - 03:34 AM

Upgraded from w7 to w10 and had this problem with the menu screen displayed only in my left monitor and in a small portion of it.
The solution for me was to change some settings in my Ati drivers and viola!

Attached Files


Edited by tikfas, May 03 2020 - 03:34 AM.


#31 syd_drake

syd_drake

    Bruce McLaren

  • Members
  • PipPipPip
  • 23 posts
  • Gender:Male
  • Interests:GPL, Assetto Corsa
  • Sim interest:GPL

Posted May 19 2020 - 02:18 PM

View PostLee200, on Apr 16 2020 - 01:02 PM, said:

Look here:

http://srmz.net/inde...23

Pay particular attention to item F.

That was it. Just how much better GPL looks in 1440p instead of 720p :)





Also tagged with one or more of these keywords: screen, resolution, gpl, grand prix legends, problems, core, rasterizer, d3d, opengl

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Sim Racing Links