Jump to content


* * * * * 2 votes

Gpl On Linux


  • Please log in to reply
120 replies to this topic

#106 Frank_Mueller

Frank_Mueller

    ---

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 203 posts
  • Gender:Male
  • Location:Stuttgart, Germany
  • Interests:Racing Sims

Posted Jan 01 2017 - 10:53 AM

It does not work for me!
I tested Mint 18 (unofficial LXDE and the official XFCE) with WINE out of the box and the 1.9.24 version.
Each tested with a fresh installation. No other effect.
IGOR slows down GPL and no chance to join.

So, i think this project gets no happy end. :hithead:
Better to serve GTP, this works smooth. :up:
But there are very less players . . . . . .

#107 alexnelson

alexnelson

    Guy Ligier

  • Members
  • Pip
  • 5 posts
  • Interests:Racing & flying sims
  • Sim interest:GPL

Posted Mar 15 2017 - 03:13 AM

Hi,

I got it working in Manjaro 17.0 / Wine 2.4 / 32bit prefix (I3 / hd7850 / AMD propriatary drivers / openglv2)
Good graphics, fps and stability.
I can run one hour long offline and online races without any trouble.

The only bug I get so far is that the screen can flicker and the mouse pointer disapears when going back to menu from in game with openglv2. With d3dv2 the buttons dont work in menu.
I found a workaround : I have "yakuake" installed on my KDE desktop. It's a terminal emulator that opens through F12 key shortcut. If I open/close it, I get back to a full usable menu

Gem+ installed and working with 60fpsv2, ffb2, 77dv4 no letterbox, carsound patches

Some trouble with Vroc :
- I get a error when trying to add a chatroom : "External exception 80000101"
- I can join servers but in game my G27 doesnt work anymore...
Although everything is ok when I join online races from game menu.

I dont use Igor.

Regarding rotation angle, the shifter button trick works:

View PostCookie, on Dec 01 2016 - 01:35 PM, said:

Maybe Marcos or Zalo can test if this works in linux
[1+2] + O = ~670°
[1+2] + S = ~450°
[1+2] + X = 900° Resets to default
[1+2] + T = ~240°

The biggest issue for me is that altough my G27 wheel is working with good FFB out of the box, I cant get any H-shifter control through Gplshift.
I can make it work with Fairshift but I just cant get used to it,
On windows i use gplshift h-shifter with clutch on for realism, although I sometine miss gears I still get correct laptimes.
Unfortunatly no way for me to achieve this with Fairshift, getting way to much neutrals when changing gears...


Marco and all others I join your crusade ;)

Edited by alexnelson, Mar 15 2017 - 04:26 AM.


#108 mcmirande

mcmirande

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 718 posts
  • Gender:Male
  • Location:Tucumán, Argentina
  • Sim interest:GPL

Posted Mar 15 2017 - 04:23 PM

Hello Alexnelson

I'm exactly at the same point than you. You're extremely welcome to our crusade, hehe.

I'm also racing online with clutch and H shifter (from begginings of this year) and am very happy with it. But unfortunately I can't do that on linux. So I'm still racing on Windows.
I tested fairshift and it works very good on linux, but I feel fairshift very unfair when I try to race against guys using either paddles or shifter but braking with the left foot and automatic clutch.

I'm not that fast and my objective is not exactly to win races or championships, but using fairshift I just wouldn't approximate to the pack, which isn't so funny...

Well. I'm happy with the new incorporation to our crusade :)

Marcos.

#109 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,603 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Mar 20 2017 - 07:35 AM

I have this graphical GEM+ difference between Linux and win7.
Looks like linux is using less colors or something, notice in pictures and colored buttons (see pics)
Do you guys have it too?

Attached Files



#110 mcmirande

mcmirande

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 718 posts
  • Gender:Male
  • Location:Tucumán, Argentina
  • Sim interest:GPL

Posted Mar 20 2017 - 12:15 PM

Yes... I also have differences somewhat like those...


#111 JMF

JMF

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 270 posts
  • Gender:Male
  • Location:US
  • Interests:GPL, gardening, woodworking, classic rock, modern blues, jazz-rock fusion, and sex.
  • Sim interest:GPL

Posted Apr 16 2017 - 12:02 PM

View Postginetto, on Mar 20 2017 - 07:35 AM, said:

I have this graphical GEM+ difference between Linux and win7.
Looks like linux is using less colors or something, notice in pictures and colored buttons (see pics)
Do you guys have it too?

That looks just like mine. It's grainy under Linux but mine looks fine when I enter the car.

Computer - Gigabyte AM2 motherboard, Phenom II X2 560 unlocked to 4 cores and overclocked to 3.7 Ghz, DDR2-800, and a GTX 1050ti.

I pieced together an old computer to use to get GPL working in Linux. I have FF working and it looks good in the car. I recently replaced the 10 year old nvidia 9500GT with a GTX 1050ti because the old card wouldn't maintain 60 fps whenever another car (67 F1) appeared on the track. Now I have corrupted fonts in Pribluda. That doesn't bother me a great deal but the font for the frame rate when I press ALT+F is corrupt too. I need to be able to read the frame rate to get my graphics settings correct.

So far I think I get a better frame rate with Win7 vs. Linux Mint 18 on the same computer. Until I get the frame font fixed I can't try to switch to Linux exclusively for GPL. GPL is the main reason I still use windows.

#112 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 647 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Apr 16 2017 - 02:55 PM

Greg look if wine uses Win XP in winecfg, this worked better for me than W7 emulated.

Funny thing is my best and perfect Linux GPL is mint 17.3 (old kernel) with  GPU AMD HD6870 and last fglrx drivers with a Phenom IIX2 555 @ x4 3500...

My other mint 18.1 Sys has an FX4300 @4200 with GTX660 Windforce OC, prop NV driver 378.13
This has stable 60fps and clean fonts in all aspects, perfect driving,
but it looses the mouse cursor after the return from track to main menue :rolleyes:
a switch to tty2 and back gets it back, but this is not fun...

It seems the NV driver has some bugs working with wine.

If you want any settings just ask ;)

#113 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 647 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Apr 22 2017 - 07:07 AM

Tried  Manjaro XFCE Edition (17.0.1) and it works fine with wine 2.6 and NV GPU GTX660 (375 driver) with GPL

It keeps the mouse cursor!

#114 mcmirande

mcmirande

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 718 posts
  • Gender:Male
  • Location:Tucumán, Argentina
  • Sim interest:GPL

Posted Apr 22 2017 - 08:56 AM

Great. I've Manjaro too with Gnome and it runs very well (only if I configure wine to emulate a windows desktop of the size of my screen).

Cheers. Marcos

#115 JMF

JMF

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 270 posts
  • Gender:Male
  • Location:US
  • Interests:GPL, gardening, woodworking, classic rock, modern blues, jazz-rock fusion, and sex.
  • Sim interest:GPL

Posted May 07 2017 - 01:25 PM

Results of further testing:

AMD Phenom II X4 3.7ghz / Nvidia GTX 1050ti / Linux Mint 18 Cinnamon desktop / FF working

I tried everything that was recommended to fix prib, such as every font from the M$ pack. Arial was best but it was still corrupted. Installing fonts in Winetricks didn't help either. Zalo's Pribluda.ini fixed the problem with my corrupted fonts. I'm not sure which setting was the culprit. I still I have to adjust my font size. It's too large at the moment. Frame rate display (ALT + F) was fine it was just obscured by prib.

A lot of the tricks that work in windows (reducing prib displays, turning off internet meter) to increase the frame don't work in linux as others have noted. Anti-aliasing and Anisotropic Filtering are the only two things I've seen have any real effect on frame rates. Nvidia users make sure you adjust your PowerMizer settings in NVIDIA X Server Settings to Prefer Maximum Performance when using GPL. My GPU wants to clock down to 15 Mhz on Auto when sitting idle in the desktop. I don't know if there are PowerMizer settings with the Nouveau driver. So this is in reference to the proprietary Nvidia drivers.

I'm having the same problems with losing my mouse cursor after exiting the car. ALT + Tab has been my best cure so far. You may need another program running such as a Terminal window running so alt+tab tries to cycle through the programs that are running. Changing ttys with my distro requires Ctrl+Alt+F1, F2, F3 and so on, with the F keys number being which tty is chosen. I'll look into Axel's choice of distro, Manjaro XFCE Edition (17.0.1), some day.

My menus are a little slow as others have mentioned. But the hard drive I'm testing on is very old, possibly 13 years. It's slowing things down at times.

My sound isn't very good in the 67 F1s but it's fine in the 1971 Can Ams. The motherboard is about 10 years old so the onboard sound may be one of those chips that GPL doesn't like. I need to get a HDMI cable so I can try the sound from the video card.

Some bugs with iGOR. In windows if I click the chat on or off, when I reopen iGOR it remembers if I had chat on or off. In Linux it would always open chat even though I had chat turned off when I previously closed iGOR. If you want chat on or off when you open iGOR in Linux, set the value in igor.ini.

When I host a race, GPL won't go to the track I chose in iGOR. GPL always opens with Albi showing, the first track in my season67.ini. I have to select the track from GPL.

Close everything running in Wine occasionally. After a few times of opening and closing GPL and iGOR with something always running in Wine, things start getting flaky.

I've not done much performance testing or tweaking yet. So far my impression is I can get this computer running 60fps decently. The GTs could be a problem at some tracks without reducing what is shown in GPL's settings.

A. Aliasing = 4X (4X MS) A. Filtering = 8 (3 levels)

67 F1 60fps runs well. I might get an occasional stutter. Firefox running in the background brings the frame rate down at times. I only open a file manager or terminal window now so I can alt+tab if I lose my mouse cursor.

71 Can Ams 60fps Spa67. 30 fps starting behind 19 cars. Once I'm off the line 50-60 fps. When it narrows at Eau Rouge 50-55 fps. 60fps out of Eau Rouge. I'd have occasional stutters after that, with a quick drop to 57 or 58 fps. During practice with other cars on the track, I might get as many as 4 or 5 stutters (57-58 fps) per lap.

I haven't copied all my xml patches yet so the only one I've been using so far is 60fpsnewmod.

I'll post at another time on what I've learned with this computer. AMD FX-6300 4.4 Ghz / Radeon R9 280X / Linux Mint 17.3 Cinnamon / No FF yet.

We're getting enough information in this thread that I've begun thinking I should write a condensed manual. I want to do further testing before I try that.

Thanks for the help.

#116 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 647 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted May 09 2017 - 09:25 AM

Greg my Phenom II runs GPL best when all C1E, C+Q and C6 are disabled in bios.

I just copy the installed GPL folder from W7 to .wine/c: and the use the GEMp2 installer.

#117 _Alex_

_Alex_

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 8 posts
  • Gender:Male
  • Location:Genova, Campobasso
  • Interests:IT, photography, dancing
  • Sim interest:I have no preference

Posted May 11 2017 - 12:16 AM

Ok, finally the Cd has arrived, this night I'm going to install the game.
The pack is from Sold-out software, it only wheights about 230Mb and it contains the 1.02 UK patch (I have the UK version,but I'd like to convert it in the IT version, is the 1.02 IT patch enough?).

What is the best patch to install for internet playing?

I opened a topic on Ubuntu Forums about my graphic card, good news I think:
https://ubuntuforums...d.php?t=2360782

#118 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,603 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted May 11 2017 - 02:22 AM

GPL installer 1.08 HERE
Run the installer 1.08 with your UK CD inserted then replace the gpl.exe with the one attached here.
Hope is clear enough :)

Attached Files



#119 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 647 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted May 11 2017 - 05:49 AM

Do as Ginetto said and install GPL to .wine/c:


- run gplc67.exe and create a player
- then install GEMPackage_2.5.0.32.exe , (after the install delete the gem.ini !!!) and start Gem+2 to configure it.
- replace the GPL Setup Manager  by the new v2.6.1
- edit the igor.ini (IP = blw.net)
- now, when original GPL runs ok, you can install the 55 Mod ;)

#120 JMF

JMF

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 270 posts
  • Gender:Male
  • Location:US
  • Interests:GPL, gardening, woodworking, classic rock, modern blues, jazz-rock fusion, and sex.
  • Sim interest:GPL

Posted Jun 01 2017 - 03:17 PM

Here's more of my ongoing saga.

AMD FX-6300 cpu and Radeon R9 280X gpu with Linux Mint 17.3 Cinnamon and fglrx gpu driver:

It looks good and runs well. No bugs except nothing has worked regarding FF.

AMD FX-6300 cpu and Radeon R9 280X gpu with Linux Mint 18 Cinnamon and radeon open source gpu driver:

FF works and it runs decent except OGL is unusable. D3D will run a steady 36fps but there is no way to force anti-aliasing. The lack of anti-aliasing doesn't look very good. That also made it pointless to test 60fps. I'm now guessing my problems with FF on this computer are related to the older kernel in Mint 17.3.

It's sad that AMD seems to want to ignore their GCN 1.0 gpus. I wish I hadn't bought this gpu. It's a good gpu but the driver support hasn't been good at all. I have my doubts I'll buy another AMD gpu unless they start showing a little concern for GCN 1.0 gpu owners. If they make an amdgpu open source driver for these gpus, I'll be able to use this computer for GPL in linux. If not, it looks I'll have to use a GTX gpu.

Next year I intend to build an up to date computer (cpu, mobo, and RAM). If the Radeon R9 280X gpu is still unusable for GPL in Linux, I'll use the GTX1050ti I recently bought.

If anybody wants to use linux for GPL, I'd recommend getting a GTX gpu. They have some bugs in the menus but they seem to work well in the car.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links