Jump to content


- - - - -

My Computer Keeps On Going To Sleep


  • Please log in to reply
8 replies to this topic

#1 Matrasports72

Matrasports72

    Henri Pescarollo

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Interests:SIM RACING AND AVIATION
  • Sim interest:GPL

Posted May 11 2017 - 05:07 AM

This type of problem has been happening ever since i installed GPL

After 20 mins of gameplay, My monitor just suddenly turns black although the whole PC system is still running.

The problem however is easily fixed by moving the mouse of just randomly pressing keys, but i want to prevent this issue from happening.

by the way this problem only happens with GPL, other sims like Rfactor and GP4 have no issues like this.

Hope this helps:

Intel core i5-3330 3,0GHZ
NVIDIA GeFORCE GT 520
8GB RAM
WINDOWS 8.1
64 BIT PROCESSOR

Thanks.

#2 Border Reiver

Border Reiver

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 950 posts
  • Gender:Male
  • Location:St Andrews, Scotland
  • Interests:GPL and GPL editing
  • Sim interest:GPL

Posted May 11 2017 - 05:25 AM

Turn off the screen saver / power saving in Windows. GPL is an old game and it does not tell the PC that it is active so the power saving count down just runs since the computer thinks that it is not active and so it enters power saving mode.

Rob

#3 GrandPrixYannick

GrandPrixYannick

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 745 posts
  • Gender:Male
  • Location:Netherlands
  • Interests:Check out my channel for some nice GPL content :)
  • Sim interest:GPL

Posted May 11 2017 - 05:52 AM

I have this as well. Just move your mouse cursor every 10-15 minutes on a moment where its possible. That'll keep your PC from blackscreening.

#4 Paddy the Irishman

Paddy the Irishman

    Paddy the Irishman

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 806 posts
  • Gender:Male
  • Location:Bexhill on Sea, E. Sussex, England
  • Interests:GPL; Model Cars; Photography.
  • Sim interest:GPL

Posted May 11 2017 - 06:54 AM

Strange, this used to happen to me some time ago and I fixed it but could not remember how.  Then a couple of days ago it started doing it again so I was vey pleased to see the answer here before I queried.  Perhaps the last 'Upgrade' of Win 10 did something,

I have changed the settings in 'Power and Sleep'

Edited by Paddy the Irishman, May 11 2017 - 06:55 AM.


#5 Elijahroberson

Elijahroberson

    Don Branson

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 142 posts
  • Gender:Male
  • Location:Notrealington
  • Interests:gpl, guitar, racing, history
  • Sim interest:GPL

Posted May 11 2017 - 04:47 PM

Yes, this has happened numerous times before I got annoyed and found out how to stop it in the settings.

#6 Bob Simpson

Bob Simpson

    The answer man

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,223 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted May 11 2017 - 05:25 PM

Windows 10:

Right click start button > control panel > power options > click "high performance" then go to change settings and set both settings to Never, as in the display never goes off and the computer never goes to sleep.

Windows 7:

Left click the start button > control panel > ditto the above

#7 Matrasports72

Matrasports72

    Henri Pescarollo

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Interests:SIM RACING AND AVIATION
  • Sim interest:GPL

Posted May 12 2017 - 12:54 AM

Thanks guys

I will just turn off the screen saver and go from there.

#8 Keyser Zose

Keyser Zose

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Interests:GPL
  • Sim interest:GPL

Posted May 19 2017 - 07:08 AM

Hi guys , this started up on my machine a couple of weeks ago , Ive checked all the boxes and done everything in the contropanel options , everything is set to never sleep basically but its still there , seems kinda random. I can drive a practice session with no issues and in the race the screen drops out after 7 - 10 laps. This is utterly weird cause Ive always made sure to turn off all those things in windows, no alerts of any kind really and its been working fine here without a glitch for years and ive never seen or had this issue before but all of a sudden a few weeks back it started and I still havent found the answer.

#9 Paddy the Irishman

Paddy the Irishman

    Paddy the Irishman

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 806 posts
  • Gender:Male
  • Location:Bexhill on Sea, E. Sussex, England
  • Interests:GPL; Model Cars; Photography.
  • Sim interest:GPL

Posted May 19 2017 - 07:59 AM

If you are on Win 10,
Right  click Windows Start> Left click >Systems >Settings >Power and Sleep> Screen and Sleep In drop downs “When Plugged in” Never and Never.
That is what worked for me.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links