Jump to content


- - - - -

Installing Gpl 55 Mod On Windows 98 Se


  • Please log in to reply
8 replies to this topic

#1 markmanroe

markmanroe

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 6 posts
  • Sim interest:GPL

Posted May 11 2018 - 07:16 PM

Am trying to install the 55 mod onto a Windows 98 SE machine that already sucessfully runs an older version of GEM+ and GPL 67, GPL 69, GPL 66 and GPL 65.  I am trying to do a clearn install on my new D: drive.  First the GPL Installer ver. 1.08 did not run (error message that it doesn't run on my version of Windows) so I did a manual install of GPL 1.2.02 and the new rasterizers.  Next tried to install Buenos Aires and got the same incorrect version of Windows error statement.  I've done searches on Google and SRMZ for any solutions but came up empty handed.   Any ideas?  Has anyone successflly installed the GPL 55 Mod in Windows 98 SE?  If so, how?  Thanks.

#2 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,321 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted May 11 2018 - 08:57 PM

You'll have to describe exactly what happens when you try to do the install of the 55 mod. Or is it just that it woun't run after installing it?

What "old" version of GEM are you using?

#3 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted May 12 2018 - 08:38 AM

I think current track and mod installers don't work in win 98. You need to install mod and track on one of later systems and then copy all mod files to win 98 gpl install.

#4 markmanroe

markmanroe

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 6 posts
  • Sim interest:GPL

Posted May 12 2018 - 12:38 PM

Bob, thank you for your interest.  To directly answer your questions:  I have not even been able to get to the point of installing GEM+ or using the 55 mod installer.  I am currently stuck at the point of installing the 55 mod-specific tracks like Buenos Aires.  To clarify, the information in my original post about an earlier install of GPL (including GEM+ 2.5.9) was simply to establish that my old Windows 98SE computer is capable of running GPL mods as well as GEM+.  I am trying to install the 55 mod on a new install of GPL, following the directions from the mod’s website at 55f1.gplworld.de.  Using the GPLPS Installer (version 1.08 as recommended by the 55 mod website), I put my GPL disk in the computer, tried to start the installer and got the following error message, “This program does not support the version of Windows your computer is running.”  To bypass the installer, I installed GPL manually and updated it to GPL  1.2.0.2.  As recommended by the 55 mod website, I also installed Nigel Pattinson’s rasterizers, created a new player to use with the 55 mod, adjusted the desktop resolution and game controls and then confirmed that GPL worked.  According to the 55 mod website’s directions, the next step is to install the 55 mod tracks.  I started with the Buenos Aires track.  Clicking on the track .exe I got the same Windows error message as I got the same Windows error message I got when I tried to use the GPLPS Installer.  At this point I suspect I may get similar Windows error messages if I ever get to the point of running the 55 mod installer and trying to install GEM+ 2.5.32.  Any questions or suggestions?  In response to my help request, Pavel wrote that he believes the current track and mod installers don’t work in Windows 98.  He suggested installing the 55 mod on a later system and copying all the mod files to my Windows 98 system.  I do have access to a Windows 7 computer and could install the 55 mod on it.  Could I then just copy the entire Windows 7 GPL-55 mod folder and put it on my Windows98 computer, or is it a case of taking specific files from the Windows 7 GPL-55 mod installation and putting them in specific spots on the Windows 98 GPL-55 mod installation?  If it’s the case of specific files in specific places, what  files would I put where?  Thanks ahead of time for your help.

#5 markmanroe

markmanroe

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 6 posts
  • Sim interest:GPL

Posted May 12 2018 - 12:42 PM

Pavel, thanks for your reply to my post.  I suspect you are correct about modern mod and track installers not working with Windows 98.  That's a shame since I am sure there are many older computers like mine that can run GPL and its mods just fine once they're installed.  I do have access to a Windows 7 computer and could install the 55 mod on it.  Could I then just copy the entire Windows 7 GPL-55 mod folder and put it on my Windows 98 computer, or is it a case of taking specific files from the Windows 7 GPL-55 mod installation and putting them in specific spots on the Windows 98 GPL-55 mod installation?  If it’s the case of specific files in specific places, what  files would I put where?  Thanks for your help.

#6 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted May 12 2018 - 01:50 PM

Yes, you can. Just create temp gpl folder on your Win 7 PC. Put there gpl.exe because installers need this file. Then install mod and track into this temp folder and then just copy whole folder to your Win 98 machine. Everything should work :)

#7 markmanroe

markmanroe

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 6 posts
  • Sim interest:GPL

Posted May 12 2018 - 04:22 PM

Pavel, I’ll try it and let you know.  Thanks!

#8 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 857 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted May 13 2018 - 05:46 AM

Afair W98se was a 16bit OS!

I doubt you can port new tracks and make them run...

The specialist should be Achim Kraft who is still running W98, so ask him ;)

#9 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,819 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted May 13 2018 - 06:14 AM

The tracks should work, just don't use the 32bits horizon option if available; is the installer that doesn't support older OS.

55MOD MIGHT not work since it MIGHT have some 32bits textures in it; I'm not sure though if we ever used such mips in55MOD.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links