Jump to content


- - - - -

Slow Screens Using Oglv2


  • Please log in to reply
25 replies to this topic

#1 gliebzeit

gliebzeit

    Targa Fan

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,721 posts
  • Gender:Male
  • Location:Florida - USA
  • Interests:Old guy stuff...
  • Sim interest:GPL

Posted Nov 02 2017 - 12:56 PM

Since changing laptops and video cards (currently Intel i7 with 8GB RAM and nVidia GeForce 930M with 2GB VRAM) I am using OGLv2 which gives me beautiful graphics and smooth frame rates either when in-car or with replays, although I only use 36fps.

The issues that I continue to have, since changing from D3D7v2 to OGLv2, are that the small screen in the upper right-hand corner shows the cars in a very, very jerky motion (when there are more than 2 or 3 cars in view).  Also, at the end of a race the "spinning newspaper" just moves around and round like a slideshow.  I can live with these two issues, but thought that I would ask your opinions as to what setting I might change to alleviate those problems.

Edited by gliebzeit, Nov 03 2017 - 08:15 AM.


#2 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 785 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted Nov 02 2017 - 01:47 PM

View Postgliebzeit, on Nov 02 2017 - 12:56 PM, said:

The issues that I continue to have, since changing from D3D7v2 to OGLv2, are that the small screen in the upper right-hand corner shows the cars in a very, very jerky motion.
Do you mean screen in race weekend menu? If yes then I also have same problem. Cars become 'jerky' only when session time/race standing is open on the left. If I open entry list, or track map, or my lap times then cars motion again become smooth.

Edited by Pavel, Nov 02 2017 - 01:48 PM.


#3 gliebzeit

gliebzeit

    Targa Fan

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,721 posts
  • Gender:Male
  • Location:Florida - USA
  • Interests:Old guy stuff...
  • Sim interest:GPL

Posted Nov 02 2017 - 02:18 PM

Yes, Pavel, that is the same for me.  How about the 'spinning newspaper' after a race completes and you start to go to the newspaper?

#4 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 785 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted Nov 02 2017 - 02:36 PM

Same story here, Greg. Newspaper spins very slowly. And I haven't find solution.

Also be careful. When in race weeken with qualy/race standing open you will try accelerate time then AI results can become corrupted. So it's better to switch to another program page and then start time acceleration.

Edited by Pavel, Nov 02 2017 - 02:36 PM.


#5 leon_90

leon_90

    Lorenzo Bandini

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,331 posts
  • Gender:Male
  • Location:Italy/Puglia
  • Interests:everything that has a Ferrari V12 inside
  • Sim interest:GPL and P&G

Posted Nov 02 2017 - 02:37 PM

View Postgliebzeit, on Nov 02 2017 - 02:18 PM, said:

Yes, Pavel, that is the same for me.  How about the 'spinning newspaper' after a race completes and you start to go to the newspaper?

I got both issues since quite some time.
There was a turning point but so much time has passed that I don't remember anymore what was it :( I learned to live with it. Would be interesting to know if ATI users have them too :huh:

#6 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 694 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Nov 02 2017 - 03:34 PM

Yes I have the same issues here with NVidia GPU GTX 960 and OpenGLV2 and last NV driver...

And NO, ATI has no problems with it! I just had reinstalled my HD7970 (vs GTX 660) and all ran smooth in the menues and newspaper.

IMO it has to be a buggy OGL driver of NVidia!!!
When you close the chat it is less, so I think has to do with the fonts :angry:

Edited by Cookie, Nov 02 2017 - 03:37 PM.


#7 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 1,676 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted Nov 03 2017 - 07:50 AM

I also have the slow 'spinning newspaper' problem.
Nvidia GeForce GTX 970 here, using OpenGL v2, running on 36 FPS

#8 paul skingley

paul skingley

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 457 posts
  • Gender:Male
  • Sim interest:GPL

Posted Nov 03 2017 - 11:16 AM

I have those errors too, but I can't remember when it started.

I have always used Nvidia GTX cards ever since 3dFX went under.

I have memories of normal newspapers and no jerky small screen but maybe that was with the original OGL raster.



Paul

#9 gliebzeit

gliebzeit

    Targa Fan

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,721 posts
  • Gender:Male
  • Location:Florida - USA
  • Interests:Old guy stuff...
  • Sim interest:GPL

Posted Nov 03 2017 - 11:41 AM

Just a little more info for my case in particular.  My previous laptop also had a discrete nVidia graphics card and memory .... though less powerful than my current laptop description in Post #1.  With that laptop (2009) I ran D3D7v2 because of comments at the time that it was better for both quality and frame rate - which were true.  Both current issues were not present with D3D.

The two issues started with my more powerful laptop after I changed to OGLv2.  My change from D3D to OGL was to eliminate the massive flickering in the menus (which was not there on my previous laptop using D3D).

Edited by gliebzeit, Nov 03 2017 - 02:59 PM.


#10 Millennium

Millennium

    Roger Williamson

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 271 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:GPL
  • Sim interest:GPL

Posted Nov 03 2017 - 12:49 PM

I've had none of those problems in OGLv2 with my HD7850 and R9 290X, so it must be Nvidia related indeed.

Edited by Millennium, Nov 03 2017 - 12:50 PM.


#11 leon_90

leon_90

    Lorenzo Bandini

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,331 posts
  • Gender:Male
  • Location:Italy/Puglia
  • Interests:everything that has a Ferrari V12 inside
  • Sim interest:GPL and P&G

Posted Nov 03 2017 - 02:19 PM

View Postgliebzeit, on Nov 03 2017 - 11:41 AM, said:

The two issues started with my more powerful laptop after I changed to OGLv2.  My change from D3D to OGL was to eliminate the massive flickering in the menus (which was not there on my previous laptop using D3D).

Yes Greg, these issues do not happen on d3d. Problem is, as you mentioned, that d3d has massive flickering (which also didn't use to happen a while back).

Seems like the green team is not that good for GPL. I am starting to considerbuying a mule card from ATI just for GPL, and keep using the 970 for other titles :huh:

Edited by leon_90, Nov 03 2017 - 02:19 PM.


#12 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,243 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Nov 03 2017 - 07:15 PM

I can’t help but think this is a problem with the display not coping well with the 640x480 res of the menus. Can you try running GPL in-car at 640x480 to see if it is as good as at the higher res?

#13 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 694 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Nov 04 2017 - 03:43 AM

Bob all menues are in 640x480 and the setup and options work fine.

The turning newspaper must be an animated object that causes troubles. Can we kill this?

If you have the chat active in the main menue, the tv screen is slow, but when you close the chat it gets normal...

Edited by Cookie, Nov 04 2017 - 03:44 AM.


#14 gliebzeit

gliebzeit

    Targa Fan

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,721 posts
  • Gender:Male
  • Location:Florida - USA
  • Interests:Old guy stuff...
  • Sim interest:GPL

Posted Nov 04 2017 - 06:30 AM

Bob, I just tried setting the in-car / replay resolution to 640x480.  I was distracted by something when you first mentioned that test last night.  In 640x480 the in-car and replay are smooth as with my native resolution of 1920x1080.  So, that's not the issue.

Axel, of course all menus are always in 640x480.  As for chat being active in the main menu ... I never drive online, but use only the AI, so I never have chat active - still get the slow down in the small upper right-hand window and with the newspaper spin after a race is completed.

I have never tried to run GPL in a window on my Win 7 desktop.  Maybe another test.

Edited by gliebzeit, Nov 04 2017 - 06:31 AM.


#15 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 694 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Nov 04 2017 - 06:41 AM

View Postgliebzeit, on Nov 04 2017 - 06:30 AM, said:


I have never tried to run GPL in a window on my Win 7 desktop.  Maybe another test.

To run GPL in a window you must reduce the colordepth to 16bit, but W7 will not let you do it...

Greg do you know the file that makes the newspaper spin ?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links