Jump to content


* * * * * 5 votes

Gpl Engine Sound (Gples) V1.0


  • Please log in to reply
147 replies to this topic

#61 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted Oct 01 2014 - 03:16 AM

View PostBrian Speake, on Sep 29 2014 - 03:04 PM, said:

Lee, I can't get this working, think I have installed the files/folders in the correct place and have clicked the saved sounds/delete mod exe button. What happens is the sound for the car I am driving plays as a low volume buzz, the other sounds of skids/passing cars are ok and reasonable volume. Just occaisionally the real sound seems to kick in for the car driven but then reverts to the buzz a few corners later.If I untick the two choices in GEM+/options sound is ok again.
It looks like game was patched successfully but your system couldn't mange all sound files or maybe part of new sound files are damaged (because download process was aborted for example).

#62 M Needforspeed

M Needforspeed

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,491 posts
  • Gender:Male
  • Interests:GPL - start a collection of GPL era die cast racing cars -Skiing
  • Sim interest:GPL

Posted Oct 01 2014 - 11:14 AM

Brian ,

  There as been so many threads in the past at RSC about the problem on how very sensitive GPL accept or not changes in the sound folder,  so reinstalling your sound card  driver can be an option to test .

I understand that your sound works OK with others sounds folders/carset, but give it a try, and suddenly GPL will "accept" to play ALL the sounds correctly;

This happened to some GPlers that successfully corrected the pbs ,  by trying a back and forth process with their driver / sound card

Edited by M Needforspeed, Oct 01 2014 - 11:22 AM.


#63 Brian Speake

Brian Speake

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 150 posts
  • Gender:Male
  • Location:Herefordshire, UK
  • Interests:Rugby
  • Sim interest:GPL

Posted Oct 01 2014 - 11:56 AM

Lee, attached is debug file, I have tried downloading file and installing the files in again same result. As I said strange thing is that sometimes after an off/ctrl-R sound is working, next off and its gone again.

Attached Files



#64 Pavel

Pavel

    Bruce McLaren

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male
  • Location:Minsk, Belarus
  • Interests:Racing, Simracing, Music
  • Sim interest:GPL

Posted Oct 01 2014 - 12:43 PM

Brian,
Dx8vb.dll from Lee's archive is missing in your main GPL folder. All other files look ok.

Edited by Pavel, Oct 01 2014 - 12:46 PM.


#65 Lee200

Lee200

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,518 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 01 2014 - 01:01 PM

Brian, I reviewed your debug file and don't see anything obviously wrong.

Its difficult to tell if GEM+ is properly patching your donor gpl.exe.  However, my GPL Engine Sound.exe program modifies the 77B.xml file each time the program is run and exited so you should see a current date in that 77B's Date Modified field.  Then the modified 77B file is used to patch the donor gpl.exe when you run GPL assuming its checkbox is selected (as well as the 92.xml too).

Be sure to have the GPL Engine Sound.exe program in your root directory alongside the donor gpl.exe file.

Pavel, the Dx8vb.dll helper file is only needed for the Sound Editor Tool's play feature so it shouldn't be needed if the player simply wants to use the engine sound patch.

Edited by Lee200, Oct 01 2014 - 01:10 PM.


#66 Nokiabrier

Nokiabrier

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 109 posts
  • Gender:Male
  • Location:Saint-Jean-sur-Richelieu, Qc, Canada
  • Interests:GPL, Curling
  • Sim interest:GPL

Posted Oct 03 2014 - 06:03 PM

That makes it at least two of us who can't run it properly. I hope I can fix my problems soon :) Pavel is great help ATM, hopefully we'll find out :) I get no more error message now though, although the sound patch doesn't seem effective. fer.wav is still dominating my Ferrari replays lol

#67 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 772 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Oct 04 2014 - 06:08 AM

View PostNokiabrier, on Oct 03 2014 - 06:03 PM, said:

That makes it at least two of us who can't run it properly. I hope I can fix my problems soon :) Pavel is great help ATM, hopefully we'll find out :) I get no more error message now though, although the sound patch doesn't seem effective. fer.wav is still dominating my Ferrari replays lol

You'll still get the default sound in replays even when the patch is working, the Readme says "Does the Player Car Still Use a Single Engine Sound in Replay Mode--Yes"

#68 Nokiabrier

Nokiabrier

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 109 posts
  • Gender:Male
  • Location:Saint-Jean-sur-Richelieu, Qc, Canada
  • Interests:GPL, Curling
  • Sim interest:GPL

Posted Oct 04 2014 - 08:34 AM

No no ! That can't be true lol. I'm used to doing my sound checks in replay mode lol. Aw man ! I feel so dumb now lol. I actually didn't read the readme in its entirety :hithead:

Edited by Nokiabrier, Oct 04 2014 - 09:43 AM.


#69 Nokiabrier

Nokiabrier

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 109 posts
  • Gender:Male
  • Location:Saint-Jean-sur-Richelieu, Qc, Canada
  • Interests:GPL, Curling
  • Sim interest:GPL

Posted Oct 05 2014 - 01:29 PM

A WIP preview of my Ferrari 312 sound compatible with GPLES is available here :)

#70 GORDON_S

GORDON_S

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Old Europe
  • Sim interest:GPL

Posted Oct 12 2014 - 03:05 PM

Belated, but from the bottom of my heart:

THANK YOU VERY MUCH, LEE   :up:   :bravo:

I've been waiting for this for years, at least since Petteri (brr) announced something similar that unfortunately never materialized.

IMHO this is your most important patch so far, as (like others) I think that sound has been the weakest part of GPL.

Now all we need are good sound-sets with soft transitions. My hopes are with new designers stepping in (Nokiabrier) and old masters returning.
Jeroen, Wolfgang, where are thou...?

#71 John Woods

John Woods

    Be Somebody

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,468 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Oct 12 2014 - 04:09 PM

Thank you Lee!

These new sounds take awhile to get used to, and have forced me to focus on and be more aware of other things. With familiar engine sound gone I've been searching for something else to rely on, and that's making me see familiar tracks in new ways.

Gammaworx skid sound is muffled, btw, or seems so?

Do different sounds play when using in-car driver view compared to cam12, (roll bar)?

Looking forward now to some full orchestra instrumentals.
How does this new feature compare with other racesims?

#72 Lee200

Lee200

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,518 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 12 2014 - 04:52 PM

You're welcome guys.  :)

I was hoping, and still do, that someone will design sound sets for all the mods, but so far, no one except Nokiabrier has indicated any interest in doing so.  :(

It is what it is and I'm not losing sleep over it as there are other things to work on...such as the '55 mod which by the way does include the fabulous Mercedes W196.  :)

AFAIK, all of our former sound experts are gone for good.  So it's up for others to step up now and do so.

John, the Read Me states that the replay mode (such as the roll bar view) still uses the single engine sound.  The real time in car and F10 views are the only ones where you will hear multiple engine sounds.

I've no idea how this sound enhancement compares to other sims...are there other sims?  :)

Edited by Lee200, Oct 12 2014 - 05:29 PM.


#73 John Woods

John Woods

    Be Somebody

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,468 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Oct 12 2014 - 05:32 PM

IIRC, N2003 uses three sound files for each engine.

Using roll bar view as driver view so I can tweak it with carcamedit.
There is now definitely very different car sounds compared to before installing GPLES, and they changed entirely with Lotus or Ferrari sounds installed.
Roll bar view has always played engine sounds, but not other sounds like wind, that I recall hearing when using default driver view.

Edited by John Woods, Oct 13 2014 - 07:00 AM.


#74 JonnyA

JonnyA

    Perry McCarthy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 587 posts
  • Gender:Male
  • Location:Dorset, UK
  • Interests:Historic motor sport, sailing, astrophotography
  • Sim interest:GPL

Posted Nov 14 2014 - 01:14 PM

I've just tried this for the first time - it's very good, thanks for making the effort, Lee.

#75 Bastian Grupp

Bastian Grupp

    Bruce McLaren

  • Members
  • PipPipPip
  • 21 posts
  • Gender:Male
  • Interests:GPL
  • Sim interest:GPL

Posted Nov 15 2014 - 09:25 AM

Hi,

I tried to follow your install instructions, but after running the .exe it says it cant find the 77sound.xml file even i put it into gem+/options. i didn't have an extra folder between (gem+/gpl67/options/)

I tried this as well but it has the same error message. Any Ideas ?

Thanks in andvance,
Bastian

#76 qwertyce

qwertyce

    Jimmy Clark

  • Members
  • PipPipPipPipPipPipPipPip
  • 44 posts
  • Gender:Male
  • Location:Sicily
  • Interests:gpl
  • Sim interest:GPL

Posted Nov 23 2014 - 06:45 AM

it's amazing! thank you Lee200!

#77 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,325 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Nov 23 2014 - 12:14 PM

View PostBastian Grupp, on Nov 15 2014 - 09:25 AM, said:

Hi,

I tried to follow your install instructions, but after running the .exe it says it cant find the 77sound.xml file even i put it into gem+/options. i didn't have an extra folder between (gem+/gpl67/options/)

I tried this as well but it has the same error message. Any Ideas ?

Thanks in advance,
Bastian

You don't show the whole path - it should be \Sierra\GPL\Mods\GEM+\gpl67\options

I'm guessing that you incorrectly put into the \GPLSecrets\GEM+\Options folder

#78 qwertyce

qwertyce

    Jimmy Clark

  • Members
  • PipPipPipPipPipPipPipPip
  • 44 posts
  • Gender:Male
  • Location:Sicily
  • Interests:gpl
  • Sim interest:GPL

Posted Nov 25 2014 - 02:58 PM

I have a bug with gples, before it was all ok, but now I can't listen anymore the ferrari engine noise at high rpm, over about 9000 rpm engine becames mute, I can't understand what's happened or if the bad is mine, I don't remember to have changed something about gples

#79 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 879 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted Nov 25 2014 - 07:34 PM

Did you change the settings outside of GPL? If you have a different car selected the range of sound gets screwed up leading to no sound above the defined range.

#80 qwertyce

qwertyce

    Jimmy Clark

  • Members
  • PipPipPipPipPipPipPipPip
  • 44 posts
  • Gender:Male
  • Location:Sicily
  • Interests:gpl
  • Sim interest:GPL

Posted Nov 26 2014 - 07:47 AM

View PostMichkov, on Nov 25 2014 - 07:34 PM, said:

Did you change the settings outside of GPL? If you have a different car selected the range of sound gets screwed up leading to no sound above the defined range.

it's like you wrote, but I don't remember, but now it's working :thanks:




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Sim Racing Links