Jump to content

- - - - -

Gem+ Troubleshooting With Windows Locale

  • Please log in to reply
2 replies to this topic

#1 SV3000


    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 152 posts
  • Gender:Male
  • Location:B.C. Canada
  • Interests:all kinds of racing games
  • Sim interest:I have no preference

Posted Aug 12 2018 - 07:25 AM

GEM+ is known (but not by many) to malfunction under some non English like windows locale (such as Japanese/Chinese/Korean), and it's one thing that keeps away people from playing GPL. Common error such as "GEM+ can't find or recognized gpl.exe", "GEM+ or GPL crash".

Here is some troubleshooting that I gathered and tested, hope it helps.

First, guide on how to change and test windows locale setting (anyone can do this, whether it's a English version windows or  Japanese version or French etc.):

In Windows XP:
Go to control panel, find "Regional and Language", open and select "Advanced" tab, under "Language for non-Unicode programs", select a language you need to test, then press OK and restart computer.

In Windows 7/8 (win10 might be similar):
Go to control panel, find "Regional and Language"(win7) or "Region"(win8), open and select "Administrative" tab, click "Change system locale".

PS: If you have a perfectly working GPL and GEM+ setup and using English or similar windows system, and want to test this whole locale thing, just do the following:
1. Change your locale to either Japanese or Chinese (as both are reported most), then reboot system as asked.
2. Go to your GPL folder and remove any previous exe that created by GEM+, such as gplc67.exe
3. Start GEM+ and hit green button to run GPL.
4. Check the troubleshooting section below for reference.


The following issues would probably happen when using GEM+ under various locale setting:

Attempt to install GEM+ in a non English locale system such as Japanese/Chinese/Korean:
1. something like "code 123" or "Error 123" error (fail to create or move file) while installing, though installation can still be completed.

Assume GEM+ is installed and "GEM.ini" doesn't exist in "GPLSecrets\GEM+" folder:
1. Upon launching GEM+, you will be asked to locate gpl.exe folder. However after click "Add" in "GPL Installation Maintenance" dialogue and select correct gpl.exe, an error pops out as "An error has occurred from which GEM+ cannot recover...", and then GEM+ hangs. Click "Search" button will result the same error once it finds the exe.
(iirc some older GEM version won't create "GEM.ini" after installation. Newest version do create "GEM.ini".)

Assume GEM+ is installed and ran at least once under English or similar locale, or having correct "GEM.ini" file, then start GEM+ in a non English locale system such as Japanese/Chinese/Korean etc,
1. GEM+ will start normally.

2. Click green GPL button will generate a new (corrupted) exe. By running this exe (gplc67.exe in my example), one of following bugs may happen:
a. Field of view is broken (very low fov, see screenshot in this post http://srmz.net/inde...?showtopic=7824), adjusting the number in GEM+'s "Field of View (Dergrees)" has no effect.
b. Game will crash as soon as you on the track.
c. Car has little to no power, throttle useless, whether with "Throttle Help" or not.
d. Car cannot move, cannot shift gears.
(As always, before generate a new exe in GEM+, don't forget to delete any old exe that created by GEM+, such as gplc67.exe)

3. Attempt to "Add" other gpl.exe in "GPL Installation Maintenance" dialogue will return "Exe not valid as a GEM+ base exe" error.

4. There may be other errors too, such as this: http://srmz.net/inde...?showtopic=8242

5. This post (author from Japan seems) also confirms the locale effect on GEM+: http://srmz.net/inde...=30#entry132888


There is no real workaround that I know, sadly. The only option is to switch system locale to English while using GEM+.
The big downside is, requiring system reboot everytime locale is changed, and running system daily under a different locale is not an option, since it will break a lot other non-English program.
However exe that generated under English locale do work under other locale. So it's a good idea to generate exe once in English locale, then switch back to your default locale.

PS: I have tested "Microsoft AppLocale", but proved no use. This topic had brought up a few times many years ago, but couldn't find those original posts. Please let me know if anything missed, thanks.

Edited by SV3000, Aug 13 2018 - 02:11 PM.

#2 John Woods

John Woods

    Be Somebody

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,843 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Aug 12 2018 - 10:03 AM

Just wondering, is it possible to run GEM+ inside an "English partition" on the HD?
Know it works across partitions, (C:/Eng, E:/Eng), as long as it all gets installed in the same partition, because that's my setup atm.

Learned this after HD crash.
Tech recovered most of it and copied it all onto a partition on the new HD, so all of GPL, GEM+, etc now sits on E-drive.
Thinking none of it would work, started GPL and it worked fine.
Starting GEM+ did not work.
The problem found was GEM+ had, I guess, created some files it wanted to use on the C partition, then apparently did not find them when opening on E?
Otherwise, how did the files get on the C-drive?
Anyway, copied them to where they were supposed to be on the E partition, deleted the others, and since then its worked great.

Really good post btw.
Hopefully working thru these issues will help others with interest in Grand Prix Legends.


Edited by John Woods, Aug 12 2018 - 10:18 AM.

#3 SV3000


    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 152 posts
  • Gender:Male
  • Location:B.C. Canada
  • Interests:all kinds of racing games
  • Sim interest:I have no preference

Posted Aug 12 2018 - 12:01 PM

Hi John Woods,

Thanks for the suggestion. The core problem is about windows' old "ANSI code page" thing, with different locale setting, some program that coded with specific non-unicode code page will display and read file paths & names incorrectly (many with unreadable Mojibake) from a different locale system, which is causing the issue.

Someone did make a thread a few years ago asking GEM+ author to make the program support unicode, so it can run on any kind of windows system, but if I remembered correctly the author replied that he/she didn't have a windows (that displays asia language or something) to test, and that discussion ended there. I don't know much about programming, but since all it needs for testing is changing the locale setting in whatever version of windows one has. So I still think it's possible, if the original author willing to take a deeper look.

Either way it's a wonderful program, thanks for the hard work all the people put into. Hope one day it can run on anyone's system without trouble.

Dug up a few posts that reported with GEM+ problem, which are most likely due to locale setting, listed below for reference, will update if finds more.

Gem+ Won't Run After Mod Been Installed (chinese windows locale) http://srmz.net/inde...?showtopic=9492
Gem+ 2 Trouble http://srmz.net/inde...?showtopic=9906
Gpl Point Of View Problem (this post's author has chinese name, most likely using chinese locale) http://srmz.net/inde...?showtopic=7824

Edited by SV3000, Aug 12 2018 - 03:35 PM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links