Jump to content


- - - - -

Extremely Noisy Engine Sounds


  • Please log in to reply
16 replies to this topic

#1 veeman

veeman

    Chris Irwin

  • Members
  • PipPip
  • 10 posts
  • Interests:GPL, slot racing, Time Trials.
  • Sim interest:GPL

Posted Mar 19 2017 - 07:18 PM

Gentlemen,
I hope someone can help with this problem. No matter what GPL mod I run, the engine sounds for all cars is extremely noisy. Way down in the noise, I can hear the various engines especially the Ferrari and Eagle v12s and the BRM H16.

I am using an HP desk top running Windows 8.1. Processor speed is 3.4GHZ with 8 GB of Ram and am using a set of Sennheiser earphones. I am not using a graphics or sound card. I have the 65-69 and the F2 mods installed. They all work very well, just the noise problem.

When I use the earphones for other purposes, they work very well with no noise or static.

I have spent several hours searching thru this website for help, but have had no luck so far. I know just enough about computers to get in trouble, so any help cannot be too basic.

#2 Paddy the Irishman

Paddy the Irishman

    Paddy the Irishman

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 792 posts
  • Gender:Male
  • Location:Bexhill on Sea, E. Sussex, England
  • Interests:GPL; Model Cars; Photography.
  • Sim interest:GPL

Posted Mar 20 2017 - 03:29 AM

Open your ;mod', Click Options, use arrows on the bottom to get to Sound and Gameplay, Adjust Volume slider on left hand side of the window. I hope this fixes it  !

#3 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,584 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Mar 20 2017 - 05:27 AM

Try to set it like in the pic here:
Low volume and 8 sounds.

Attached Files



#4 John Woods

John Woods

    Be Somebody

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,091 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Mar 20 2017 - 09:07 AM

Either a too much load, wrong setting somewhere, or related corrupt file somewhere.
Probably.

Copy gpl/sounds folder to a safe place.
Then in gpl/sounds delete all files except the DAT, so only oem sounds will play.
Try that and if sounds work correctly it is too much load.

Add the add-on sounds back in one at a time.
Maybe start with the car you prefer atm, then add more.
You can make any sound file a car sound file.
For instance, once tried jet taking off sound.

After that probably most important is skid.wav.
Tire sounds indicate tire patch and suspension loading.
Unsure what you have...maybe try this one: Gamma's Skid Sounds

If that doesn't work likely it is something outside of Grand Prix Legends.
Try turning acceleration down a notch.
Think you will find that in "dxdiag" or somewhere in computer performance settings.

Edited by John Woods, Mar 20 2017 - 10:49 AM.


#5 twinpotter

twinpotter

    Richard "Dick"Seaman

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,284 posts
  • Gender:Male
  • Location:leeds,England
  • Interests:Motor Racing
    Motorbikes
    computer gaming-
  • Sim interest:GPL

Posted Mar 20 2017 - 11:24 AM

If other methods do not work and as John mentions, it may be a problem outside GPL.

On bottom task bar right click sound speaker Icon- SOUNDS/PLAYBACK/SPEAKERS/PROPERTIES/ADVANCED

You should see 'Allow applications to take exclusive control of this device' plus 'Give exclusive mode applications priority' plus look at 'Allow hardware  acceleration of audio with this device'
Try ticking and un-ticking with experimentation.

Hope this helps ?

TP: :think:

#6 veeman

veeman

    Chris Irwin

  • Members
  • PipPip
  • 10 posts
  • Interests:GPL, slot racing, Time Trials.
  • Sim interest:GPL

Posted Mar 20 2017 - 01:23 PM

Thank you gentlemen. I'll give all those suggestions a try.

#7 twinpotter

twinpotter

    Richard "Dick"Seaman

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,284 posts
  • Gender:Male
  • Location:leeds,England
  • Interests:Motor Racing
    Motorbikes
    computer gaming-
  • Sim interest:GPL

Posted Mar 20 2017 - 01:47 PM

No problem Veeman

Just come back here, if you are still struggling. Also if you solve your issue, let us all know how ! As it helps us problem solve and reference, for the future !

TP: :rolleyes:

Edited by twinpotter, Mar 20 2017 - 01:48 PM.


#8 asd111222

asd111222

    Ludovico Scarfiotti

  • Members
  • PipPip
  • 8 posts

Posted Mar 20 2017 - 07:32 PM

You could substitute engine sounds using the ones you like

#9 veeman

veeman

    Chris Irwin

  • Members
  • PipPip
  • 10 posts
  • Interests:GPL, slot racing, Time Trials.
  • Sim interest:GPL

Posted Mar 21 2017 - 01:27 PM

Gentlemen,
Paddy and Ginetto- Reducing the vol. slider to almost zero and the number of cars to 3, probably made the biggest improvement.

John- I sound several sound files in the Sound folder such as Fire, Gravel, Hit and Skid. I have deleted them all (I did make a backup folder). There was even a "Static" file there! It is gone too. When I deleted all the files except DAT, the sim would not open up. I reinstalled all files and took out those mentioned above and the sim will open. I have not been able to find "dxdiag" or anything about acceleration on my computer.

Twin Potter- I tried your suggestion, but it made very little difference.

asd111222- I will try your suggestion also.

All in all there has been perhaps a 25% improvement. Maybe that is as good as it gets.

I know nothing about sound cards, but I wonder if some cards have controls to damp or amplify different frequency ranges. I think that damping low freq. sounds might help. Any words of wisdom on that thought and if it is worth a try may I have a few suggestions of which card to purchase?

I certainly appreciate the help you gentlemen have provided. GPL and the GPL community are the best!!

#10 Yngwie

Yngwie

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 211 posts

Posted Mar 21 2017 - 02:15 PM

View Postveeman, on Mar 21 2017 - 01:27 PM, said:

I have not been able to find "dxdiag"...

Hit Windows-Key + R on your keyboard. Type: dxdiag. Hit enter. Should do the trick ;)

Edited by Yngwie, Mar 21 2017 - 02:15 PM.


#11 John Woods

John Woods

    Be Somebody

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,091 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Mar 21 2017 - 02:29 PM

The files you removed are only used when they are called for, like when you run over gravel or there is a fire.
Probably you could put them back if they don't make things worse.
Anything outside the DAT is an enhanced file created by an editor for us to enjoy.
Sometimes the bigger size of enhanced files gets in the way.

That the most improvement is by reducing load suggests that might be the main issue?
But you have to take it too far to have any good effect.
Most systems I would guess should run 4 sounds with good quality at max in-game volume.
But that isn't always the case.

What about FPS? Did framerate improve as well?

#12 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,584 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Mar 22 2017 - 05:55 AM

You might also want to try to check your sound drivers.
I did an update of mine and realized that made things worse for GPL so I went back with the default ones found in the builder site, in your case HP.

#13 Gartner

Gartner

    Jo Gartner - Helmuth Koinigg - Hermann P. Müller Karl Kling

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 100 posts
  • Gender:Male
  • Interests:GP History, Music
  • Sim interest:GPL

Posted Mar 22 2017 - 03:30 PM

you could also try to reduce the hardware acceleration to basic acceleration (control panel>sounds>speakers>advanced>system performance).
maybe it helps. oops, this has already been recommended via dxdiag.

Edited by Gartner, Mar 22 2017 - 10:22 PM.


#14 veeman

veeman

    Chris Irwin

  • Members
  • PipPip
  • 10 posts
  • Interests:GPL, slot racing, Time Trials.
  • Sim interest:GPL

Posted Mar 23 2017 - 11:48 AM

Thank you all gents. I am still struggling with this. I will keep you posted.

#15 veeman

veeman

    Chris Irwin

  • Members
  • PipPip
  • 10 posts
  • Interests:GPL, slot racing, Time Trials.
  • Sim interest:GPL

Posted Mar 26 2017 - 10:22 AM

Well, I think this post can be closed as I have achieved success to the point that I am satisfied with the engine sounds. There is still some noise, but nothing like before. After spending many hours trying this and that, I borrowed a set of desk top speakers and they made a large improvement. Also in the Windows 8.1 control panel I found a control entitled "IDT Audio Control Panel". By using that I was able to adjust the frequency response from 31 Hz to 16 KHz. Those were the two items that made the most improvement.

In view of that, I am now the owner of a set of desk top speakers and a Sound Blaster Audigy FX sound card. The card obviously provides better sound and it has the frequency adjustment option also.

I also have discovered that the "Max. number of sounds" and the "Volume" sliders in the "Sound and Gameplay" screen in GPL have no effect on the sound. A few days ago I thought they did, but not now.

Thanks to all who provided suggestions for improvement. I tried almost all of them. As I said before, GPL people are just great.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links