Jump to content


- - - - -

Gem Ai Settings Not Working


  • Please log in to reply
4 replies to this topic

#1 summerski

summerski

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 81 posts
  • Gender:Male

Posted Jul 22 2020 - 03:59 PM

All has been nearly flawless until I installed the Can-Am mod today. Now now matter what number (usually between .97 -1.03) I set the AI Speed to in GEM, they all record about the same times.

I tried to speed them up at Mid-Ohio and noticed nothing changed so I tried the 67 mod at Kyalami and also no change. Even set them to .50 and Clark was still setting pole at 1:20XX/

Any help/suggestions would be greatly appreciated.

I very much enjoy racing the AI and fine tuning their speed via GEM.

Thanks!!

Will



npt_override = .83                     ; set to > 0.0 to override normalized player time

.83 is the same result as .53 , .93 etc

Edited by summerski, Jul 22 2020 - 04:34 PM.


#2 summerski

summerski

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 81 posts
  • Gender:Male

Posted Jul 23 2020 - 11:17 AM

The only way I can get the AI to run properly is to set the speed in GEM then back out and run from the GPL exe.

I did try deleting the  GPLc67 and did a rebuild but still all the AI run as if they're set to 0 no matter what GEM is set to.

I also tried changing the "Installs" mapping in GEM but no luck there either.

I did read Lees AI guide which is very helpful but still can't pinpoint the error.

Thanks.

#3 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,835 posts
  • Gender:Male
  • Interests:Football
  • Sim interest:GPL

Posted Jul 23 2020 - 12:46 PM

Unless a mod .exe is corrupted and hasn't gotten fully patched, then loss of AI control is not due to the .exe.  Rather, it's more likely that GEM+ is not changing the npt_override setting in the mod's gpl_ai.ini file.

GPL reads and uses the npt_override setting and knows nothing about GEM+.  GEM+ simply modifies the npt_override setting prior to starting GPL.  It is a convenience included with GEM+.

You can manually edit the mod's npt_override setting yourself and then start the mod .exe directly without using GEM+.  You must make sure to modify the correct gpl_ai.ini file for the mod.  If this doesn't affect the AI speed then there is something else wrong.

#4 summerski

summerski

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 81 posts
  • Gender:Male

Posted Jul 23 2020 - 02:36 PM

View PostLee200, on Jul 23 2020 - 12:46 PM, said:

You can manually edit the mod's npt_override setting yourself and then start the mod .exe directly without using GEM+.  You must make sure to modify the correct gpl_ai.ini file for the mod.  If this doesn't affect the AI speed then there is something else wrong.

Thanks Lee for reaching out. Yes I can override the settings manually and the AI work perfect.  I'll have to this going forward. No big deal just a bit frustrating after the AI in all the mods were working perfect thru GEM until I installed the CAN-AM Mod yesterday. I even uninstalled it and still have problem. Just one of those GPL deals.

One thing I do notice when I start the gpl.exe manually, I see the old welcome screen and not the updated one I get when starting via GEM.

Also the AI are working as they should in the 66 MOD via GEM.

Thanks for your help!!

Will

Edited by summerski, Jul 23 2020 - 02:43 PM.


#5 Lee200

Lee200

    Denny Hulme

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 1,835 posts
  • Gender:Male
  • Interests:Football
  • Sim interest:GPL

Posted Jul 23 2020 - 03:28 PM

That's good that you can manually edit the mod npt_override setting and control the AI speed which means the mod .exe is working OK.  :)

Apparently, GEM+ is the culprit and is not modifying the mod's gpl_ai.ini file properly.  This may be due to a corrupted gem.ini file and the best way to fix that is to delete the existing one and reinstall your mods to GEM+.

BTW, you do know that GEM+ has a bug and will not modify the '67 F1 "mod's" gpl67.ini npt_override setting.  So it cannot control the AI speed for the gplc67.exe.  You must do it manually.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Bing (1)

Sim Racing Links