Jump to content


* * * * * 1 votes

Gpl Replay Camera Distortion - Solved

GPL Replay Camera Graphics Settings GPLShift

  • Please log in to reply
9 replies to this topic

#1 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,839 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Oct 10 2018 - 09:40 AM

TL;DR? Just read the final few paragraphs after the "code" section for the fix! :P ;) :D

Hi all. For some time I've noticed that replay camera images in GPL can become distorted, with extreme zooming, inverted and reversed images, and even distorted textures in some cases. I've mentioned this in various graphics-related threads before, but few people have noticed the same thing, or appear to be bothered by it. Nobody seemed to have any idea what was causing the problem, or how to fix it. As I rarely watch replays myself I put it down to GPL's old and sometimes quirky behaviour, and mostly forgot about it. However, a recent post about distorted replay images by tjc in a thread about the Reims 1954/55 track update reignited my interest and curiosity about the cause of this problem.

One of the possibilities which crossed my mind about the problem is that it may simply be track makers being reluctant to test their camera positions comprehensively. The distortion only seems to happen when the GPL cars come close to the replay camera. So I just thought that maybe the track authors had placed their cameras a bit too close to the track, to get better "action" shots. However, this was quickly denied by several people, who referred to distortion affects with certain tracks which I had reported, and which they denied seeing at all. This showed that the problem had to be connected with how individual GPL drivers had configured their installation.

Over the past few days I had some time to spare, so I thought I would effectively turn my GPL installation "upside-down" to see if I could affect these camera distortions in some way. I experimented with graphics settings in GEM and GPL directly. I tried deactivating patches which affect graphics. I tried using different rasterisers. Of course I also tried different mods and different cars. After quite a few hours of experiments, I seemed to be getting nowhere.

Then I had a thought. I have GPLShift installed in my GPL setup, to enable me to (sometimes) use my Logitech G25 wheel with the sim. It takes a bit of effort to rearrange my computer desk to set up my G25, so if I'm only going to be driving for a few minutes I usually don't bother, and stick to my trusty old CH Mach2 joystick. I switch between two different GPLShift.ini files to allow me to use either the G25 or the joystick. But GPLShift itself is always running, even when I'm not using my steering wheel. I remembered that GPLShift not only allows players to use a shifter with GPL, but that it can also be used to move the drivers' head position to get a different view from the cockpit. Obviously this is a graphical effect, so even though it shouldn't affect replay cameras, I thought I would remove GPLShift to see if it made any difference. To my surprise, when I unpatched GPL to remove GPLShift, all camera distortions in replays disappeared!

I toyed with the idea of leaving GPL unpatched, and not using GPLShift most of the time. However, when I talked with tjc in the Reims thread and let him know about my findings, he was a little disappointed, because he uses his steering wheel all the time, and relies on GPLShift. So I then started to investigate all the settings in the GPLShift.ini file to see if I could pin down the replay problems to maybe just one or two things.

After much experimentation, I found that it was a single setting in the file which seemed to be causing the problem. GPLShift supports (supported?) a device called the "Matrox TripleHead2Go", which apparently used to be used to connect multiple monitors to a computer. There's a section in the .ini file which has one setting for this. It's somewhere around line 280 to 290 in the file, and in the default GPLShift.ini file it looks like this:

[ TripleHead2Go Adjustment ]---------------------------------------------------
Adjust_InCarView = AUTO 	 ;OPTIONS:		 OFF	 AUTO		 ;EFFECT:
					 ;AUTO = Will move the CAR with Mirror inside Center
					 ;	 Monitor (Default) - Please notice: The AUTO
					 ;	 Mode will also Enable the needed [ ZOOM ]
				 ;	 Function in "Zoom_In_Out_Mode = KA" Mode
					 ;	 if GPLshift find it Disabled, (OFF) But you
					 ;	 can always change [ ZOOM ] Mode to using
					 ;	 POV or BUTTONs, See under here for saving
					 ;	 changed (TH2G) position, ("UserDefineFOV")
					 ;--------------------------------------------------

Notice the default setting is set to "Adjust_InCarView = AUTO". When I first started using GPLShift, I studied the settings file to see how to set up my G25 shifter and the buttons on the wheel. But there were many sections (such as this one) which I didn't understand, and which seemed irrelevant to me. So I left them alone. But now, I tried changing this "Adjust_InCarView" setting to "OFF", and it seems to work!

When this setting is set to "OFF", I can have GPLShift active, but all the problems with replay cameras appear to be solved. And although I haven't had time to set up my G25 to try it out, tjc has tested this change with his steering wheel and confirms that everything seems to work normally as before, except that the camera distortions are missing.

So, if you're having problems with GPL replay cameras occasionally doing weird things, check if you're running GPLShift. If you are, then try editing this setting in the GPLShift.ini file to see if it improves things. My bet is that your replay problems will disappear.

As I've mentioned, this fix hasn't been tested extensively. If you can try it out, I would be grateful to get some confirmation that it works for everyone, and that me and tjc haven't just been lucky in some way!

I hope it helps! :thumbup: :wave:

Edited by Saiph, Oct 10 2018 - 09:56 AM.


#2 tjc

tjc

    Jim Clark

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 705 posts
  • Gender:Male
  • Location:Scotland.
  • Interests:Various
  • Sim interest:GPL

Posted Oct 10 2018 - 11:05 AM

Hi Saiph,

Great idea to start a thread for this in this forum. Far better than continuing to chat about it in the Reims thread. As I`ve said in there, I`m very grateful to you for all the testing you`ve done on this and also for coming up with the fix.

I appreciate these distortions might never have even been noticed by those that don`t watch replays and to be fair, GPL is really about driving but I, and some others, really enjoy taking and editing screens in dear old GPL so having replays that work properly is quite important. To me anyway. :)

Thanks again for all the work on this. Glad I was able to help a little with it. :thumbup:

tj

#3 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,839 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Oct 10 2018 - 02:24 PM

tj, your mentioning the problem in the Reims thread convinced me that there really was a problem to be investigated. Previously I'd just dismissed it and learned to disregard the weird camera shots as "just one of those things". And your quick response to my findings with the TripleHead2Go setting helped confirm that I was on the right track. Thanks for your help. :hat-tip: :up:

(P.S. Good luck with the house move. It can be a stressful time, so I hope it goes well. Will ye no be havin' a housewarmin' party? Ah could nip round wi' a wee dram? ;) :D)

#4 bob williams

bob williams

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 93 posts
  • Gender:Male
  • Interests:Simracing
    Cycling
    Legos
    RC
  • Sim interest:GPL

Posted Oct 10 2018 - 03:57 PM

Thanks saiph! I’ve always wondered if I was the only one with this problem! 👍🏻

#5 tjc

tjc

    Jim Clark

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 705 posts
  • Gender:Male
  • Location:Scotland.
  • Interests:Various
  • Sim interest:GPL

Posted Oct 10 2018 - 05:14 PM

View PostSaiph, on Oct 10 2018 - 02:24 PM, said:

tj, your mentioning the problem in the Reims thread convinced me that there really was a problem to be investigated. Previously I'd just dismissed it and learned to disregard the weird camera shots as "just one of those things". And your quick response to my findings with the TripleHead2Go setting helped confirm that I was on the right track. Thanks for your help. :hat-tip: :up:

(P.S. Good luck with the house move. It can be a stressful time, so I hope it goes well. Will ye no be havin' a housewarmin' party? Ah could nip round wi' a wee dram? ;) :D)

Hey Saiph,

Yeh, as I`ve said before. I`ve seen these weird camera distortions before on other tracks but not that many and over a long period of time. But also like you I just thought it was one of GPL`s "quirks" and thought I`d have to put up with it. It was only when I saw it as bad as it was that I decided to post about it. Anyway, I`m glad that by posting about it a solution seems to have been found. Happy I was able to help. :)

Cheers re the house moving and yeh, if I get my way it`ll be celebrated for sure. Wi more than a wee dram too. If you`re up this way pop round and we`ll have one (or maybe two... or three :lol: B) ;))

#6 John Woods

John Woods

    Be Somebody

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,441 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted Oct 10 2018 - 06:27 PM

Nice work Saiph.

Good story too.


Here's to many more.
:D

#7 marco lenarduzzi

marco lenarduzzi

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 199 posts
  • Gender:Male
  • Location:brome lake Quebec, Canada
  • Interests:racing sims,cars, F1,cooking,skiing
  • Sim interest:GPL

Posted Oct 10 2018 - 08:49 PM

Great detective work Saiph :thumbup:

#8 Tato

Tato

    sinner, but simmer

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 324 posts
  • Gender:Male
  • Location:near Verona, Italy
  • Interests:GPL, Dirt Rally, watching real races, modeling
  • Sim interest:GPL

Posted Oct 10 2018 - 11:45 PM

.Hello Saiph, You are my man! Really!

Since I've reworked cams positions at some tracks, from time to time, at least in the last 12 years, I've noticed this issue too, particularly with some angles and zoom, as you correctly spotted. But have not a single clue about the reason, not mentioning a solution, and simply 'survived with it' along the years.

So many thanks for having not overlooked this, and my praise for founding a so brilliant solution, really.

I go for it ASAP, I will report if something goes wrong.

:wave:

#9 Saiph

Saiph

    Drives 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,839 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. sims, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Oct 13 2018 - 02:59 AM

Well this is a bit odd. I've just tried starting up GPL, and it's crashing to desktop when I press the green button to go to the track. If I edit my GPLShift.ini back to "Adjust_InCarView = AUTO", it works. :censored: I am continuing to investigate...... :report:

EDIT: Ok, I've got things working again, but I'm really confused as to why I started getting problems with a configuration which I thought was stable and working only a few hours ago! :huh:  I've had to adjust some other settings in the GPLShift.ini file to get things running again. However, the changes I've made are a little bit convoluted, and seem quite illogical to me. I won't detail them here at the moment in case I end up confusing people. If others can run ok by simply changing the Adjust_InCarView setting, then it's best to leave it there. However, if anyone else still reports problems after changing Adjust_InCarView, especially if GPL starts crashing when they try to go to the track, then I'll give more details of what I've done.

I'm glad your setup is still working ok tj. The fact that it's only me with this new problem seems to suggest that it has something to do with my specific installation.

Edited by Saiph, Oct 13 2018 - 06:05 AM.


#10 tjc

tjc

    Jim Clark

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 705 posts
  • Gender:Male
  • Location:Scotland.
  • Interests:Various
  • Sim interest:GPL

Posted Oct 13 2018 - 03:22 AM

All working ok here Saiph. Keep us posted.





Also tagged with one or more of these keywords: GPL, Replay, Camera, Graphics, Settings, GPLShift

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links