Jump to content


- - - - -

Bouncing Cars


  • Please log in to reply
8 replies to this topic

#1 kennoe

kennoe

    Jack Brabham

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 48 posts
  • Gender:Male
  • Location:Australia

Posted Jul 01 2009 - 05:10 AM

I recent posted a replay showing the AI bouncing in the pits and on the grid. It was in a post about new AI for Solitude and the response was that a file had become corrupted. There were no replies which told me which file it was and I promptly forgot about it as I did not go back to Solitude.

Tonight I decided to race the 67 AI at Mexico in preparation for an on-line race next weekend and what do I see - bouncing cars. I thought maybe its the 60fps patch but it wasn't. The sound patch - no. Was it confined to Mexico? No. Tried both Monaco and Monza and each had bouncing cars. Found a thread which suggested there may be a missing file - Papycpu.sys which could be the cause. But the Patch Inspector shows that file is there.

So I am at a loss. Does anyone know which file is the culprit?

Thanks

Steve

#2 Bob Simpson

Bob Simpson

    The answer man

  • Moderator
  • 2,389 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Jul 01 2009 - 06:18 AM

It's one of the AI ini files.  I'm not sure but possibly the driver.ini, gpl_ai.ini (for the 67 cars) or related mod ini file.

#3 kennoe

kennoe

    Jack Brabham

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 48 posts
  • Gender:Male
  • Location:Australia

Posted Jul 02 2009 - 04:02 AM

Thanks Bob. It appears I did not have a gpl.ai.ini file in the GPL directory. I fixed it by renaming the gpl.ai.ini.preGEM.

I wonder if this file is somehow changed with the installation of the 60fps AI patch? I noticed I have a gpl.ai.60fps.ini but no gpl.ai.ini.

Cheers

Steve

#4 Kai Åberg

Kai Åberg

    Jo Siffert

  • Supporter
  • PipPipPip
  • 24 posts
  • Gender:Male
  • Location:Helsinki, Finland
  • Interests:Sim-Racing, Skiing, Cycling, Jogging, Windsurfing
  • Sim interest:GPL

Posted Jul 02 2009 - 09:05 AM

Hi Steve!

The 60 fps patch shouln't effect the original gpl_ai.ini file. The zip file includes a file called gpl_ai_60fps.ini which should produce better working 67 AI when playing GPL at 60 fps. To use it you should first back up your original gpl_ai.ini file by renaming it to something else like original_gpl_ai.ini for example and then rename gpl_ai_60fps.ini to gpl_ai.ini. Maybe you just deleted the original gpl_ai.ini file and therefore had very weird behaving AI drivers because GPL always need to have a file called gpl_ai.ini file in the main gpl directory if you want to race against the AI in the 67 cars.

Anyway, I'm glad you got the problem fixed. See you on Sunday in the race at Mexico.  :)


Cheers

Kai

#5 ezechiel47

ezechiel47

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 354 posts
  • Gender:Male
  • Sim interest:GPL

Posted Jul 02 2009 - 10:45 AM

View Postkennoe, on Jul 2 2009, 04:02 AM, said:

Thanks Bob. It appears I did not have a gpl.ai.ini file in the GPL directory. I fixed it by renaming the gpl.ai.ini.preGEM.

I wonder if this file is somehow changed with the installation of the 60fps AI patch? I noticed I have a gpl.ai.60fps.ini but no gpl.ai.ini.

Cheers

Steve

Very glad you found the missing file.
Good race.
Ez

#6 miklkit

miklkit

    airhead

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,137 posts
  • Gender:Male
  • Location:left coast, U.S.A.
  • Interests:GPL
  • Sim interest:GPL

Posted Jul 02 2009 - 01:59 PM

Ah.  So that was it.  I knew it was something simple, but because RSC was down I couldn't search for "bouncing cars".  Still have the replay.   :D

#7 Brocky05

Brocky05

    King of the Mountain

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 270 posts
  • Gender:Male
  • Location:The Long And Winding Road
  • Interests:I'm Way Too Addicted to GPL For Anything Else
  • Sim interest:GPL

Posted Aug 28 2019 - 12:22 AM

after a rebuild of my aging computer i reinstalled GPL using gplinstall 1.08

i am now having the same problem with the bouncing cars

but unlike the op i do have both driver ini and gpl ai ini files also  drvc67 ini in my GPL directory

any help with a fix or a file or two would be much appreciated

#8 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 3,070 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Aug 28 2019 - 01:54 AM

You need gpla67.ini too.
Every mod must have its own gplxxx.ini file

Attached Files

  • Attached File  inis.7z   7.59K   7 downloads


#9 Brocky05

Brocky05

    King of the Mountain

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 270 posts
  • Gender:Male
  • Location:The Long And Winding Road
  • Interests:I'm Way Too Addicted to GPL For Anything Else
  • Sim interest:GPL

Posted Aug 28 2019 - 10:35 PM

yes thank you ginetto i was missing that gpla67 ini thank you




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links