Jump to content


- - - - -

Flickering Menu And Replay Buttons


  • Please log in to reply
3 replies to this topic

#1 Treetop64

Treetop64

    Jochen Rindt

  • Members
  • PipPipPip
  • 29 posts
  • Gender:Male
  • Interests:Motor racing, biking, historical aircraft
  • Sim interest:GPL and P&G

Posted Jun 30 2019 - 05:45 PM

Finished reinstalling GPL/GEM/etc after the Windows re-install.  Just one issue remains.  The old menu and replay button flickering problem is occurring.

On the previous installation before the wipe (exactly the same hardware, OS, drivers, etc. as now) there was a fix that eliminated the flickering while using high Anti-Aliasing settings, but for the life of me I cannot remember what that fix was.  Nor can I find it in the forums after much searching and Google raiding.

Hopefully I've asked these old noob questions for the last time.

Any suggestions are appreciated.  Thanks!

Win7 64 bit.
EVGA GTX-950
Nigel's Rasters v2.5 / rd3d7v2.dll

#2 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,281 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted Jul 01 2019 - 02:42 AM

I found this at the

GPL FAQ and Troubleshooting Guide
http://srmz.net/inde...?showtopic=3714


Quote

There is flickering in the menus but not in-car.
- Usually this is caused when using higher anti aliasing settings on the desktop. You can try using a higher resolution for GPL in-car with lower FSAA settings. It seems that at 2xFSAA there's little or no menu flickering.


IIRC I only had flickering in the GPL menus when I was using D3D v2 (many years ago) no matter which FSAA settings I used.
I don`t have it anymore since I am using OpenGL v2.
Have you tried in GEM+ setting to OpenGL v2?
OpenGL v2 should also be more FPS friendly but on some systems D3D v2 works better. You have to try what is best for you in the menus and when you are racing with a full grid.

Edited by Stefan Roess, Jul 01 2019 - 02:45 AM.


#3 Treetop64

Treetop64

    Jochen Rindt

  • Members
  • PipPipPip
  • 29 posts
  • Gender:Male
  • Interests:Motor racing, biking, historical aircraft
  • Sim interest:GPL and P&G

Posted Jul 01 2019 - 09:08 AM

Thanks for the suggestion.

Tried OpenGL but it came with issues of its own.  Slower menu response, cycling the desktop when switching between the game and menu, artifacts around text during replays.

Just discovered the problem with rd3d7v2, though.

Went through the Core.ini and discovered that the [ RasterV2 ] section was duplicated at the very bottom of the page but with default settings, overriding my preferred [ RasterV2 ] settings earlier in the page.  Simply copying my settings to the duplicate fixed the issue.  Figured I might as well keep the duplicate section anyway since, for whatever reason, GEM put it there.  Didn't bother erasing it only for GEM to possibly put it back again with defaults.

Edited by Treetop64, Jul 01 2019 - 09:22 AM.


#4 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,020 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Jul 01 2019 - 03:01 PM

Wich NVidia drivers do you have installed?
Wich CPU is running?
Have you installed GPL with the last "all-in-one" installer 1,08 ?

Your GTX 950 should run gpl perfect in OpenGL!

Seems your install is messed up, so no good idea to try repairing!!! Save your time for racing...

Try Stefans Grand Prix Legends Easy Installation Guide




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Sim Racing Links