Jump to content


- - - - -

Problems with GPL Digital Display w/Vista 64


  • Please log in to reply
29 replies to this topic

#1 godzilla85

godzilla85

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Sim interest:GPL

Posted Apr 27 2009 - 05:39 PM

Hi all,
I am having problems getting the GPL Digital Display mod to work with GPL. I am running Vista 64 HP and keep getting the error message "Error 0 running command exe". I have tried the usual Vista tricks to try and get this program to run but with no luck. Whats weird is my old rig ran Vista 32 HP and I was able to use this mod. My version of GPL has these mods installed :
gpl v1.2.02 us all in one
gplinstall max _0.97us
Nigels GPL v2.5
I also have the 60 (?) FPS mod installed also.
Any suggestions?

#2 Lee200

Lee200

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,472 posts
  • Gender:Male
  • Sim interest:GPL

Posted Apr 29 2009 - 07:02 AM

View Postgodzilla85, on Apr 27 2009, 05:39 PM, said:

Hi all,
I am having problems getting the GPL Digital Display mod to work with GPL. I am running Vista 64 HP and keep getting the error message "Error 0 running command exe". I have tried the usual Vista tricks to try and get this program to run but with no luck. Whats weird is my old rig ran Vista 32 HP and I was able to use this mod. My version of GPL has these mods installed :
gpl v1.2.02 us all in one
gplinstall max _0.97us
Nigels GPL v2.5
I also have the 60 (?) FPS mod installed also.
Any suggestions?

godzilla,

The author of GPL Digital Display is no longer actively involved with GPL so if it is not working with Vista 64, then it probably never will unless someone can make Vista 64 compatible.

Lee

#3 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Apr 29 2009 - 07:08 AM

View PostLee200, on Apr 29 2009, 04:02 PM, said:

The author of GPL Digital Display is no longer actively involved with GPL so if it is not working with Vista 64, then it probably never will unless someone can make Vista 64 compatible.

Lee

DDM does run in Vista 64, but perhaps the installer does not.

#4 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Apr 29 2009 - 07:11 AM

I will check later this evenning. Maybe I can build a new installer which runs on vista 64 bit.

#5 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Apr 29 2009 - 12:34 PM

Please contact Stefan from GPL++ for an updated version of his installer.

Edited by Bernd Nowak, May 03 2009 - 07:03 AM.


#6 godzilla85

godzilla85

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Sim interest:GPL

Posted Apr 29 2009 - 06:59 PM

View PostBernd Nowak, on Apr 29 2009, 02:34 PM, said:

Try this one :) Download, unzip and run the installer. Should run.

WOOOOOHOOOO! Thanks Bernd! Just downloaded and installed works great :thumbup: Thanks you for your help :clap2:

#7 Kanzo

Kanzo

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 354 posts
  • Gender:Male
  • Location:Helsinki
  • Sim interest:GPL

Posted Oct 16 2009 - 01:38 AM

My old version of GPLDDM is still working though I now have Vista 64 on my new PC. It´s a powerful computer and should be able to run even the heaviest tracks in 60 fps but all the same I´m having strange frame rate problems especially when there are chat messages or someone is disconnecting. Brr suggested that GPLDDM could be one reason for the poor performance (OGLv2) so I´d like to try to 1) run GPL without GPLDDM and 2) try this new version if it helps.

So, two questions:
1) How do I uninstall GPLDDM?
2) Where can you d/l the new version? GPL++ / Utilities / Lee and Stefan - GPL Digital Display Modifier is the home of GPLDDM but the date of those download files is 2003-04-23??? Or is it the new version anyway?

#8 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 16 2009 - 02:57 AM

View PostKanzo, on Oct 16 2009, 10:38 AM, said:

I´m having strange frame rate problems especially when there are chat messages or someone is disconnecting. Brr suggested that GPLDDM could be one reason for the poor performance (OGLv2)

Only in the sense that DDM uses the same text rendering method which is used to print chat messages. The join/leave thing might be partly explained by GPL doing something to update driver information.

Quote

2) Where can you d/l the new version?

Why don't you simply backup the current gpl.exe, and switch back to it after testing?

#9 Kanzo

Kanzo

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 354 posts
  • Gender:Male
  • Location:Helsinki
  • Sim interest:GPL

Posted Oct 16 2009 - 04:02 AM

View Postbrr, on Oct 16 2009, 11:57 AM, said:

Why don't you simply backup the current gpl.exe, and switch back to it after testing?


Thanks for the suggestion, Brr.  :wave:
But the thing is I already tried to install it on top of the old one but could not figure out which one I was using so I guess I first need to uninstall the old one to be sure...

#10 brr

brr

    a GPL editor

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,244 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 16 2009 - 04:34 AM

Here's a little patch (so far 10 seconds of testing so use at own risk) to switch off DDM in case you have a DDM patched gpl.exe. Install to GEM+ Options folder and check the checkbox.

Use "Save As" to get the file, otherwise it will probably open in a browser or some editor.

Attached Files


Edited by brr, Oct 16 2009 - 04:35 AM.


#11 miklkit

miklkit

    airhead

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,137 posts
  • Gender:Male
  • Location:left coast, U.S.A.
  • Interests:GPL
  • Sim interest:GPL

Posted Oct 16 2009 - 08:31 AM

Ahh. I have been wanting something like this for a while.  When in OGL both DDM and Pribluda are running, possibly causing fps issues.

#12 Kanzo

Kanzo

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 354 posts
  • Gender:Male
  • Location:Helsinki
  • Sim interest:GPL

Posted Oct 16 2009 - 09:23 AM

That was it! You´re the man, Brr!!  :bowing:

I disabled GPLDDM altogether as the new version caused the same problems. No more hickups, I´m back to steady 60 fps even at the back of a full grid with Monaco Rocks, 1920*1080 resolution and all the eye candy! PLUS Pribluda. Pheww... finally.  :clap:


:applause:

Edited by Kanzo, Oct 16 2009 - 09:26 AM.


#13 giorgio

giorgio

    Bob Anderson

  • Members
  • PipPip
  • 17 posts
  • Sim interest:GPL

Posted Oct 18 2009 - 06:50 AM

Hi ,

I have the same fps problem even with GPLDDM  disabled or uninstalled;

uninstalling pribluda too solves this problem , but I'd like to use it  (I don't use GPLDDM).


I have noticed  an error into rastolog.txt  :  " OpenGL error at .\DisplayOpenGL.cpp:324 valeur non valide"  ?

Georges

#14 Frenchy

Frenchy

    Denny Hulme

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 531 posts
  • Gender:Male
  • Sim interest:GPL

Posted Oct 18 2009 - 08:20 AM

View PostKanzo, on Oct 17 2009, 01:23 AM, said:

That was it! You´re the man, Brr!!  :bowing:

I disabled GPLDDM altogether as the new version caused the same problems. No more hickups, I´m back to steady 60 fps even at the back of a full grid with Monaco Rocks, 1920*1080 resolution and all the eye candy! PLUS Pribluda. Pheww... finally.  :clap:

I tested this myself and I can't even get 36fps at the back of a full grid at Monaco Rocks, 1680x1050 all graphics options on and detail at 50. I tried all rasters and openGLv2 was the best (before it stopped working, see other post). 60fps was down to 40fps. I'm not running DDM. Turning off the display of Prib (F5 etc) helped a little but not a lot.

What specs/settings are you running please Kanzo. I have a quad core IntelQ9300 (2.5GHz), 4 gig ram, nvida 9600gt 512mb under Vista32.

Cheers
David

Edited by Frenchy, Oct 18 2009 - 08:22 AM.


#15 giorgio

giorgio

    Bob Anderson

  • Members
  • PipPip
  • 17 posts
  • Sim interest:GPL

Posted Oct 18 2009 - 09:06 AM

View PostFrenchy, on Oct 18 2009, 04:20 PM, said:

View PostKanzo, on Oct 17 2009, 01:23 AM, said:

That was it! You´re the man, Brr!!  :bowing:

I disabled GPLDDM altogether as the new version caused the same problems. No more hickups, I´m back to steady 60 fps even at the back of a full grid with Monaco Rocks, 1920*1080 resolution and all the eye candy! PLUS Pribluda. Pheww... finally.  :clap:

I tested this myself and I can't even get 36fps at the back of a full grid at Monaco Rocks, 1680x1050 all graphics options on and detail at 50. I tried all rasters and openGLv2 was the best (before it stopped working, see other post). 60fps was down to 40fps. I'm not running DDM. Turning off the display of Prib (F5 etc) helped a little but not a lot.

What specs/settings are you running please Kanzo. I have a quad core IntelQ9300 (2.5GHz), 4 gig ram, nvida 9600gt 512mb under Vista32.

Cheers
David

Hi,

btw, my specs are : Vista 64 SP1 (running gpl in 32 bits , of course) , Nvidia 9600 GS 768 mb, quad core Q9400.

I have noticed that another cpu core is heavily used while typing  ,especially when a very long message is being entered (not even sent) ;
fps drops from 36 to 10 , then  returns to 36 after the message has been sent.  


I have tested  on my own pc also (using it as both client and server).


Georges

Edited by giorgio, Oct 18 2009 - 09:09 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links