Jump to content


- - - - -

New Player Menu Input Woes

gamepad controller xbox 360 input joystick calibration controls

  • Please log in to reply
3 replies to this topic

#1 Cold Turkey

Cold Turkey

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Interests:Board-games
  • Sim interest:GPL

Posted Aug 03 2018 - 08:41 AM

Hello new friends!

The other day I installed GPL for the first time using the 1.08 installer and a French ISO from a good abandonware site with no issues, other than one missing readme file.

Upon firing it up for the first time all was well; I made a profile, set the steering to the keypad and successfully putted around Spa.

I don't have a wheel handy, so I plugged in a 360 gamepad and upon launching I'm stuck on the joystick calibration window. I can't click "OK," the green flag, or the right arrow. It recognises the sticks and at least one trigger (the other may be on the next page that I can't view without being able click the arrow). No keyboard buttons, mouse buttons or gamepad buttons allow me to advance. If I remove the gamepad the problem persists.

I have tried reinstalling the game, deleting the player profile (this allows me to remake a profile in-game, but then clicking the green flag always advances to the joystick calibration window) and plugging in the gamepad at various different times (before startup, before launching GPL, in-menu, in joystick calibration and in-game) to no avail.

I am on Windows 10, and using the XBCD 0.2.7 driver for the gamepad to split the trigger axis (the native driver suffers the same problem).

Googling and lurking this forum bore no fruit unless I'm blind. Is this a simple rookie error and I'm just a simpleton? I apologise in advance if I've overlooked the obvious.

Thank you kindly.

#2 Millennium

Millennium

    Roger Williamson

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 372 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:GPL
  • Sim interest:GPL

Posted Aug 03 2018 - 09:16 AM

Do you have one of the 60 fps patches enabled? Enabling the wrong patch can make all the menu buttons unresponsive. Also, do you have other usb devices plugged in besides your controller, keyboard and mouse?  The controller should always be plugged in before you start GPL and choose 'Direct Input' instead of 'Generic' when going in to callibration.

I've used a 360 controller with GPL for a long time, it should work perfectly. I've always used the original drivers by Microsoft and even though the triggers are seen as one axis you can still assign each of them as throttle and brake. (One will be positive, the other negative) So I would recommend going back to the original drivers that came with the controller anyway, no software for seperate axis is needed.

Here is proof by the way:
https://www.youtube....h?v=QSLJ1eCBtTQ

Edited by Millennium, Aug 03 2018 - 09:41 AM.


#3 Cold Turkey

Cold Turkey

    Jackie Ickx

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Interests:Board-games
  • Sim interest:GPL

Posted Aug 03 2018 - 12:18 PM

Problem solved.

I reinstalled GPL and ran into the same issue, but while it was stuck in joystick calibration I was busy elsewhere. Upon returning the mouse could interact with the menu buttons again. I reinstalled the game to replicate the problem and figure out what had fixed it, but it seems that it just wants to sit on the calibration window for a few minutes when first setup. Curiouser and curiouser. I didn't have any other patches, mods or USB devices installed and it defaults to Direct Input. And my computer is solid.

I had watched that video, by the way. Is that your channel? It's been really helpful and a major reason why I wanted to try GPL out. Thanks a bunch if it is and for your quick reply, anyway.

Now to see if I can get AA to work without making everything blurry.

#4 Millennium

Millennium

    Roger Williamson

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 372 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:GPL
  • Sim interest:GPL

Posted Aug 03 2018 - 12:45 PM

Nice that it's solved now. Yes that's my channel, thanks for the compliment! :)

For AA just use the nvidia/AMD control panel and force the highest possible AA in the profile for the game. I use 8 X Super Sampling which looks great.

Edited by Millennium, Aug 03 2018 - 12:46 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links