Jump to content


- - - - -

Fanatec Csw 2.5 Problems


  • Please log in to reply
7 replies to this topic

#1 IanMc

IanMc

    Guy Ligier

  • Members
  • Pip
  • 4 posts
  • Interests:GPL
  • Sim interest:GPL

Posted Mar 10 2018 - 12:03 PM

Hi fellow GPL fans,

Just getting back into sim racing after a long hiatus, and replaced my G27 with a Fanatec Clubsport 2.5 Wheel Base, Clubsport Formula Carbon Wheel and Clubsport Shifter.  I'm having no luck at all getting this combo to work with GPL.  The wheel works fine for steering, but GPL doesn't recognize the shifter or any of the buttons on the wheel (including paddle shifters). I've tried every possible combination of settings in gplshift.ini but nothing works.

I've installed Fairshift and deleted the gplshift.dll.  Using the "custom" button mode in Fairshift, When I go into the "configure wheel" screen, the button assignments for the H shifter match up with the "active button" when I engage a gear.  But when I go into GPL and select a gear, all I get is the staticy sound when the gear is engaged, but the car doesn't change gear and remains in neutral.  Running the 69 Mod, I tried deleting the .exe and letting GEM rebuild it, but that didn't make any difference.

So, at the moment, the only way I can play GPL is with automatic shifting, which just isn't very enjoyable.  I'm running Windows 7, 64 Bit. So, I'm stumped. Anybody else have a similar setup and managed to get it working?

Cheers!
Ian

#2 IanMc

IanMc

    Guy Ligier

  • Members
  • Pip
  • 4 posts
  • Interests:GPL
  • Sim interest:GPL

Posted Mar 10 2018 - 12:22 PM

Something else I noticed, even with the "Auto start on boot" box checked, Fairshift doesn't auto start and I have to start it manually when I reboot...

#3 IanMc

IanMc

    Guy Ligier

  • Members
  • Pip
  • 4 posts
  • Interests:GPL
  • Sim interest:GPL

Posted Mar 10 2018 - 04:00 PM

Oops, guess it would help if I engaged the clutch before selecting a gear :rolleyes: .  Problem solved, I'm back on track and absolutely loving the 1955 Mod, what a brilliant piece of work!

Still don't understand why Fairshift won't auto start on boot even though the box is checked. Any ideas?

Ian

#4 twinpotter

twinpotter

    Richard "Dick"Seaman

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 1,414 posts
  • Gender:Male
  • Location:leeds,England
  • Interests:Motor Racing
    Motorbikes
    computer gaming-
  • Sim interest:GPL

Posted Mar 11 2018 - 08:09 AM

Hi IanMc

I found the following links about Fairshift ?

If you've not seen them before, have a look through and see if they help 🤔

https://bitbucket.or...shift/wiki/Home

http://srmz.net/inde...?showtopic=9163

TP: 😁👍

Edited by twinpotter, Mar 11 2018 - 08:13 AM.


#5 IanMc

IanMc

    Guy Ligier

  • Members
  • Pip
  • 4 posts
  • Interests:GPL
  • Sim interest:GPL

Posted Mar 11 2018 - 05:08 PM

Thanks for the suggestions twinpotter, but still no luck.  No big deal really, a couple of extra mouse clicks is a small price to pay to get GPL working again.  It's nice to be back!

Cheers!
Ian

#6 francesco

francesco

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:COMO (Italy)
  • Interests:GPL
  • Sim interest:GPL

Posted Mar 30 2018 - 08:52 AM

Same problem for me as in  post1 but my difference is that i have an ACTlab shifter.Deleting GPLshift.ini and apply faishift 2.1 nothing work.
With shift.ini applied i have the first gear on the B button,2 on y ,3 on paddle up,4 on paddle down and 5 on RT button and work only with the button pushed.
The ACT work with the button:R on 1,1 on3,2 on 4,3 on 5,4on 6,5 on 7as displaied by the PC control pannel.
My Fanatec is the CSL elite with Club sport pedals V3. i have only substituted my old momo Logitech with the new Fanatec wheel.
There is a conflict between the 2 device(recognized by the PC) for the button assigned but i'm not able to find a solution.
Someone could help me?

#7 francesco

francesco

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:COMO (Italy)
  • Interests:GPL
  • Sim interest:GPL

Posted Mar 30 2018 - 10:36 AM

I have found an error,i had the enable clutch ticked. Now seem to work but i forgot in which way is chosen TN+ and TN- in the gear into the game.

#8 francesco

francesco

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:COMO (Italy)
  • Interests:GPL
  • Sim interest:GPL

Posted Apr 22 2018 - 10:43 AM

All is Ok ,i can play ,but the button of the wheel don't work into the game.If i want to assign,for example, look at right with paddle or buttton there is nothing to do.Someone have experience?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links