Jump to content


- - - - -

Win10 And Gpl


  • Please log in to reply
6 replies to this topic

#1 Bo Bruce

Bo Bruce

    oAo Admin

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 312 posts
  • Gender:Male
  • Location:northern Indiana
  • Interests:racing... baseball...military history... reading too much to specify everything :)
  • Sim interest:GPL

Posted Mar 11 2017 - 02:03 PM

my PC is now Win10 and there are a couple of annoying hiccups while racing GPL.
1.  when i'm running alone, all good, but at the start, or anytime in traffic of more than 2 other cars, my sound muffles.. every (incl my own car engine) sound gets turned down in volume - any one else? any known fix?

2. my controller is a g25, and there are times, when i turn full left/right the steering wheel will now act as if i've damaged the suspension :(    even a sh-R won't correct, but sometimes making an emphasized turn the other direction will center it again!  for practice sessions i end up exiting and having to re-calibrate.

anyone else? any suggestions?


#2 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 646 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted Mar 11 2017 - 03:56 PM

@2 what do you mean by act like the suspension is damaged? Does the car pull to one side when the steering wheel is centered?

#3 MECH

MECH

    Double poly killer

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,395 posts
  • Gender:Male
  • Location:Here ->
  • Interests:My Girlfriend
  • Sim interest:GPL

Posted Mar 11 2017 - 05:44 PM

2. Sounds like a dirty or worn out pot to me.
Guess you need to use some contact spray to solve that.

That is if it had pots but it seems to use optical recognition.
Maybe the problem is what's posted here? https://nl.ifixit.co...bration problem

#4 Bob Simpson

Bob Simpson

    The answer man

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,213 posts
  • Gender:Male
  • Location:Ottawa
  • Sim interest:GPL

Posted Mar 11 2017 - 08:38 PM

As I have already told Bo:

It seems to me that sometimes running the Logitech Profiler while racing can cause issues in GPL, so unless you’re doing some special mapping of buttons, I’d recommend shutting that software down.

#5 TvO

TvO

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 989 posts
  • Gender:Not Telling
  • Interests:Unknown
  • Sim interest:other

Posted Mar 12 2017 - 05:44 AM

If your Logitech G25 goes off centre, it might be your optical encoder wheel is cracked. It's a plastic piece which can perish over time. I took my wheel apart a couple of years ago and fixed it by carefully applying some superglue to the crack, but there are replacement brass wheels out there as well:

http://cmlaserservic...oder_wheel.html

I think that when the optical wheel cracks it slides a little bit on the shaft it is placed on, and the steering wheel loses track of which position it is in if you turn the wheel too fast (i.e. when racing). I took the optical wheel off and glued the crack, but when I put the optical wheel back on the shaft, I glued it to the shaft as well. I think having a little crack in the optical wheel is not a problem per se, but the sliding around on the shaft is. So I glued it to the shaft to guarantee it would not slide anymore and stay in place.

I used a YouTube video to know how to take the G25 apart:

https://www.youtube....h?v=EhYpWAmZVjQ

Tommie.

Edited by TvO, Mar 12 2017 - 05:51 AM.


#6 Fat Rich

Fat Rich

    Lazy Blipper

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 720 posts
  • Gender:Male
  • Location:Fallen out of the Karussell again
  • Interests:GPL has got me by the throat and won't let go.
  • Sim interest:GPL

Posted Mar 12 2017 - 06:46 AM

I had problems with Win 10 losing contact with both my G27 and G29, I plugged them into a different USB port at the back of the PC and now they're fine.... might be worth trying?

I assume it's not the number of sounds slider in the GPL Options screen that's different to your previous installation? If it's a sound muffling (rather than cutting out completely) maybe there's some kind of compressor or limiter effect applied in your sound driver's settings? Check the control panels and see if there are any effects applied to your sounds, Win 10 has some funny ideas about that sort of thing and I had to turn a load of stuff off to get the sound working properly and sounding half decent.

#7 Bo Bruce

Bo Bruce

    oAo Admin

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 312 posts
  • Gender:Male
  • Location:northern Indiana
  • Interests:racing... baseball...military history... reading too much to specify everything :)
  • Sim interest:GPL

Posted Mar 12 2017 - 09:40 PM

thanks all.. but as BobS indicated, i merely disabled the Logi-profiler and that seems to have cleared up the problem... who knew? (well, besides Bob) ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links