Jump to content


- - - - -

Gpl-G27-W10 Help!


  • Please log in to reply
2 replies to this topic

#1 Claudio Pablo Navonne

Claudio Pablo Navonne

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 253 posts
  • Gender:Male
  • Location:Buenos Aires, Argentina
  • Sim interest:GPL

Posted Feb 02 2020 - 08:12 AM

On my computer with W7 I used G27 as a steering wheel and a pedal board of another brand connected by USB port. On GPL as on rFactor and rFactor2 this combination worked perfectly. But last week the C hard drive was ruined, it was a solid state drive, there was the operating system. The technician put in a new one, and took the opportunity to install W10. Yesterday, Saturday, I started to configure everything again, I installed the G27 drivers, which against all my fears worked correctly and in the device manager the G27 was perfectly configured (apparently) the same as the pedalboard. When I enter the Logitec Profiler everything seems to be the same as before, when I play rFactor 2 everything works the same as before, but when I play GPL, the game doesn't recognize any of the buttons on the steering wheel, nor the paddles or the gear lever. I can only configure the keys of the keyboard to change the gears, turn the head, it only recognizes the movement of the steering wheel and the pedals if I connect them. I connected them to see if it was a problem of the lack of the pedalboard. Only when I disconnect the other pedalboard from the USB port it recognizes all the buttons and the gear lever. I don't want to use the G27 pedalboard, because the other one is superior.
Any suggestions?
Thanks in advance.

#2 Saiph

Saiph

    Still driving 4 Team BDS

  • Supporter
  • PipPipPipPipPipPipPipPipPipPip
  • 2,071 posts
  • Gender:Male
  • Location:Aylesbury, UK
  • Interests:Computer gaming (esp. simulations, strategy, RPG), real ale, live music, motor sports, boring the NSA/GCHQ to death.
  • Sim interest:GPL

Posted Feb 02 2020 - 02:00 PM

You didn't mention the GPLShift utility. Did you reinstall and configure it? Also, have you checked the USB device numbers that Win10 has assigned to the wheel and pedals? I've heard about people having problems if two devices are numbered in a certain order. Try changing the device numbers if you can, and make sure that the GPLShift.ini file has the right settings to find the devices.

Edited by Saiph, Feb 02 2020 - 02:09 PM.


#3 Claudio Pablo Navonne

Claudio Pablo Navonne

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 253 posts
  • Gender:Male
  • Location:Buenos Aires, Argentina
  • Sim interest:GPL

Posted Feb 02 2020 - 04:06 PM

Saiph hadn't thought about GPLShift yet, so I don't know how it can help me with this?
Instead I was thinking about the other option, but I don't know how I can change the order of the USB ports, or the devices connected to them.
Thanks anyway for your interest.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Sim Racing Links