Jump to content


- - - - -

Gpl Online: "10051: Error Found In The Network"


  • Please log in to reply
9 replies to this topic

#1 Lord

Lord

    Mr. Broken Gearbox

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 186 posts
  • Gender:Male
  • Location:Latina, Italy
  • Interests:Formula 1, Football (Soccer), Grand Prix Legends and rFactor
  • Sim interest:GPL

Posted May 24 2019 - 02:08 PM

Hi there mates.

So, I've been fancying some online laps on GPL67 (36FPS, classic 3.2.02 version): since I've been away for a long while, I did my due diligence and looked for any new info.
I've been updating the IP address, checked for new versions... everything worked fine.

Then, I decided to log in to the oAo server. the error pops up in GPL.
Try again. Same.
So I've tried MyBroga: same thing.
UKGPL: ditto.

Whatever server I was trying to log in had that kind of issue... I wonder what it might be :/

#2 Warren Hall Jr.

Warren Hall Jr.

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 181 posts
  • Gender:Male
  • Location:Cape Cod, USA, in a shack down by the river
  • Interests:Lots of stuff
  • Sim interest:GPL

Posted May 24 2019 - 02:53 PM

Sounds like a firewall issue to me. Some thing is blocking the incoming information I think.
Warren

#3 Bo Bruce

Bo Bruce

    oAo Admin

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 443 posts
  • Gender:Male
  • Location:northern Indiana
  • Interests:racing... baseball...military history... reading too much to specify everything :)
  • Sim interest:GPL

Posted May 24 2019 - 06:05 PM

what OS?   did MS update your win10?   ya never know ~ just asking

#4 Lord

Lord

    Mr. Broken Gearbox

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 186 posts
  • Gender:Male
  • Location:Latina, Italy
  • Interests:Formula 1, Football (Soccer), Grand Prix Legends and rFactor
  • Sim interest:GPL

Posted May 25 2019 - 02:04 AM

Well, it's Windows 10 Pro 1809 v.17763.503, with Kaspersky Free antivirus. I've tried pretty much everything I could to see if there was a problem with the firewall, and everything looks okay, as far as I've checked.
I'll try have another look and see where it goes.

EDIT:

Deleted all the GPL and GPLSecrets related keys from the Windows firewall, uninstalled GPL and GPLSecrets, rebooted and checked both my router and the bridge for any inconsistency: everything looked fine and firewalls on that side were disabled just to check if that was the problem..
I've installed GPL without GPLSecrets using the GPLPS 0.8 installer and proceeded to check if anything changed.
To do so, I've used the oAo IP and password.

1st try didn't bear fruit: same issue, same error... nothing changed. So I've checked the AV and disabled it for the test (I don't think Bo will bombard me with malware, after all ;) ), then put in IP and password... nothing still.
2nd try: disabled Windows firewall. No go.
3rd try: I've noticed that GPL has only "incoming" rules in the Windows firewall after the install, so I've added a new "Outgoing rule" similar to those and let the thing run. Tested, still no-show.

I don't really know what the hell is going on: I'd rather not format everything and check if that was the problem, it would be too drastic :/

Edited by Lord, May 25 2019 - 03:16 AM.


#5 Lord

Lord

    Mr. Broken Gearbox

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 186 posts
  • Gender:Male
  • Location:Latina, Italy
  • Interests:Formula 1, Football (Soccer), Grand Prix Legends and rFactor
  • Sim interest:GPL

Posted May 25 2019 - 03:30 AM

Alright, suddenly everything is working now: apparently installing GPLSecrets as admin and letting it (and the mods) access both private and public networks somehow did the trick. Can connect to every server.

Still the issue remains... it was set up exactly like this as the mess happened, so I still don't know what the actual hell happened there.

#6 John Woods

John Woods

    Be Somebody

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,582 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted May 25 2019 - 06:38 AM

Glad its working!

Likely there will be some on-line drivers practicing today at Rouen.
Come join the fun!

CU on track.
:D

#7 John Woods

John Woods

    Be Somebody

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,582 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted May 25 2019 - 08:40 AM

Just now, thought it time to start morning practice and went to join the Willow server on iGOR and do a few laps.

Timed out...abort.
Tried again...timed out again.
Checked oAo server...no problem.
Shut the server down thinking of re-doing host routine to see if that fixed issue.

A Windows update notification popped up near the clock on the taskbar.
Based on experience with unfortunate updates, had checked "notify me before installing updates."
Declined update.
Another update notification popped up, this time for Java.
Declined update.

Brought Willow server back on-line.
No problem.

So -

The update notifications, probably Windows, was causing the server to abort connections.


:D

Edited by John Woods, May 25 2019 - 09:30 AM.


#8 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
  • Location:SW Germany near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted May 25 2019 - 03:28 PM

John why do you use such an OS for a server?

GPL runs perfect in Linux/wine for hosting, without any obsessive actions of AV or OS :up:
I run GPL in windowed mode, so I can monitor and control what is happening.
Linux is fine with small and old pcs, Afaik UKGPL_10 and 11 run from the same linux pc in a VM!

#9 Stefan Roess

Stefan Roess

    Denny Hulme

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,173 posts
  • Gender:Male
  • Location:Bavaria, Germany
  • Interests:racing :)
  • Sim interest:GPL and P&G

Posted May 26 2019 - 01:14 AM

GPLRACER server runs fine on latest Windows 64-bit version with latest updates.

#10 John Woods

John Woods

    Be Somebody

  • GPLLinks Team
  • PipPipPipPipPipPipPipPipPipPip
  • 2,582 posts
  • Gender:Male
  • Interests:Too Much Fun
  • Sim interest:GPL

Posted May 27 2019 - 08:48 AM

Hi Axel,

Sorry for the GPL-time delay.
Yes I know and agree.

Priorities change, things evolve...never really know what's next.
Windows is always annoying and I am lazy.

Originally, some may recall, the plan was to set up an open 24/7 server using the 2004 Demo, with the purpose of demonstrating how easy it is to...

1) install and use Grand Prix Legends, (click-click-click...done),

2) set up a race server, (once up it is ezpz),

and 3) encourage everyone to have even more fun, get on-line and drive, practice, and race with others.

Did #1 & 2...the Willow server is hosted with the 2004 Demo on an older vanilla Win7 PC because, for me so far, that is the easiest way to do it.

Still working on #3.


"Come on in boys, the water's fine."
:D

Edited by John Woods, May 27 2019 - 11:25 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links