Jump to content


- - - - -

Installer 1.07 Ai Problems


  • Please log in to reply
11 replies to this topic

#1 juza

juza

    Guy Ligier

  • Members
  • Pip
  • 3 posts
  • Interests:Reading, writing, gaming...
  • Sim interest:GPL

Posted Mar 02 2013 - 02:16 PM

Hi,

I've just installed the lastest version of the GPL installer and found out that there's something wrong with the driver.ini. The probability for engine failure etc. is always set to 1, which means that the cars are failing everytime I race.

Is there any fix for this?

juzs

#2 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,731 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Mar 02 2013 - 05:08 PM

GPL installer doesn't modify the driver.ini.
driver ini controls the AI; not your car.
The values for engine failure of the driver.ini float around 15 to 60; not 1.
If is your engine that fails every time you race, means you're stressing it too much; try  to release the gas while change gear.

#3 juza

juza

    Guy Ligier

  • Members
  • Pip
  • 3 posts
  • Interests:Reading, writing, gaming...
  • Sim interest:GPL

Posted Mar 03 2013 - 06:20 AM

No, my engine doesn't fail. The problem affects only AI-controlled cars. Are you sure the driver.ini isn't modified? Due to the introduction of some new drivers, (I think Guy Ligier or Bob Anderson were not included in the original game) some parameters changed.

But thank you for the informative post, Ginetto. (Always thought that the probability ranged from 0 to 100 % = 1)

juza

#4 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Mar 03 2013 - 07:56 AM

You are right. There might be a problem with the driver.ini file as well as with the gpl_ai.ini file.
They are the ones from the GPL 1.3 patch.

You find the teamfix files here: (GPLDirectory)\repository\GPLPSInstaller\Teamfix\Papyrus

Please give some feedback ;)

Would still be interesting why the drvc67.ini uses such changed values.



#5 juza

juza

    Guy Ligier

  • Members
  • Pip
  • 3 posts
  • Interests:Reading, writing, gaming...
  • Sim interest:GPL

Posted Mar 03 2013 - 02:25 PM

Thank you Bernd, AI's now driving properly. But nevertheless there's another interesting bug: The 1.3 patched version miscalculates the fuel consumption. For a full race at Monza (68 laps) it assumes a maximum fuel load of 189 l for 63 (!) laps. This isn't a problem in the actual game somehow, but doing so it is rather difficult to calculate the fuel load for shorter races.

#6 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Mar 03 2013 - 02:49 PM

I checked the fuel loads in track67.ini and track.ini and there's a difference in the fuel load. Again no idea why the 1967 1.3 team changed these values.
I recall that I could remember some discussion. I feel dig a bit around :)

#7 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Mar 03 2013 - 03:06 PM

I did read the 1967 1.3 release thread and for sure there's something changed in fuel calculations. Maybe someone can tell why this was changed?
Sorry to be no real help :(

#8 Pete Gaimari

Pete Gaimari

    Jim Clark

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 3,464 posts
  • Gender:Male
  • Location:Colorado
  • Interests:Racing and Muzzleloader Hunting
  • Sim interest:GPL

Posted Mar 08 2013 - 02:49 PM

Hang on here. I'm using the 1.07 installer, and the AI are finishing my races, but I haven't run a full GP yet. Is the problem just for the full races?

#9 Bernd Nowak

Bernd Nowak

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,716 posts
  • Gender:Male
  • Sim interest:GPL

Posted Mar 09 2013 - 03:08 AM

Yes, it should only affect full GP races.

#10 Lee200

Lee200

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,452 posts
  • Gender:Male
  • Sim interest:GPL

Posted Mar 09 2013 - 08:00 AM

Bernd is right as the .exe calculates how much fuel the AI needs based on the track.ini file fuel loads and the number of race laps.  So it loads less fuel for the shorter races.  I believe the lap calculation involves some rounding up by a lap so the fuel load for a short race is proportionally more than for a longer race.

So if the track .ini fuel load is right on the edge, it may be possible for the shorter races to work and not the longer races.  The simple fix is to increase the AI fuel loads.

#11 ginetto

ginetto

    GPL track editor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPip
  • 2,731 posts
  • Gender:Male
  • Location:Lombardia, Italia
  • Interests:Mountain
  • Sim interest:GPL

Posted Mar 09 2013 - 08:17 AM

My track67.ini fuel levels are higher that the standard track.ini, not lower.
i think that 1.3 team was Paul Skingley alone.

Edited by Ginetto, Mar 09 2013 - 08:22 AM.


#12 Gui

Gui

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 153 posts
  • Gender:Not Telling
  • Interests:The world
  • Sim interest:other

Posted Nov 08 2014 - 04:51 PM

View Postjuza, on Mar 03 2013 - 02:25 PM, said:

Thank you Bernd, AI's now driving properly. But nevertheless there's another interesting bug: The 1.3 patched version miscalculates the fuel consumption. For a full race at Monza (68 laps) it assumes a maximum fuel load of 189 l for 63 (!) laps. This isn't a problem in the actual game somehow, but doing so it is rather difficult to calculate the fuel load for shorter races.

Did you just replace the ini with the one in the repository? I am having the same issues you did.




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

Sim Racing Links