Jump to content


- - - - -

Gpl 2020 Demo Only (Very) Partially Recognises Controllers


  • Please log in to reply
5 replies to this topic

#1 Timo Vermeersch

Timo Vermeersch

    Guy Ligier

  • Members
  • Pip
  • 4 posts
  • Sim interest:GPL

Posted Jan 25 2020 - 05:11 AM

Hi guys,

I downloaded the GPL 2020 demo yesterday and tried to install it.

I can however not get my controllers installed/calibrated. I run the following:
- Thrustlmaster GT500 RS wheel
- a set of old Virtual Performance Parts pedals
- an SST shifter.

All connect to the PC via USB.

When I launch the demo, it takes me straight to the controller calibration page. There it recognises only the accelerator pedal as an axis. The brake and clutch pedal are not recognised, i.e. when I push them, there is no movement on the axis page. I have the impression, but not certain, that GPL actually sees the 3 pedals as one axis. When I push the brake or clutch, there seems to be the tiniest movement on the throttle axis.

I can calibrate the steering wheel ok.

Then, in the page to assign controls, I can only assign the steering wheel and the throttle. Brake and clutch are not recognised. Also, I can not assign any action to any of the buttons on my steering wheel. GPL seems to only recognise the axis, not the buttons. As to the keyboard, GPL only seems to recognise the keypad, not the rest of the keys.

I have tried the following:
- the method indicated in the GPL 2020 info document: assign a keyboard key to brake then calibrate the controllers and then assign the actions;
- deleting the control.cfg file and restarting as proposed in the FAQ thread over here;
- installed GPL Shift as proposed in the same thread.

I always get the same result as here above.

I then tried to install GPL 2004 Demo. Same result as GPL 2020 demo. That's funny, because GPL 2004 ran perfectly on my system before. Only changes to the PC since GPL 2004 ran well are that I added an additional SSD HD and replaced the graphics card.

I'm running Win 10.

Any ideas?

Thanks in advance.

Timo

#2 Cookie

Cookie

    Chris Amon Fan

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,120 posts
  • Gender:Male
  • Location:near Hockenheim
  • Interests:Historic Motorsport, F1, MotoGP
  • Sim interest:GPL

Posted Jan 25 2020 - 06:12 AM

Hi Timo

some ideas

- in windows settings/gamecontrollers all is working and has separate axis?
- in game there can be more than one page for the calibration of the pedals (my fanatec are on the second page!)
- have you tried different USB ports? USB2 and 3...

- afaik the shifter needs GPLShift wich is not implemented, so you have to use paddles. (get a CD or .iso and make a full install ;) )

Edited by Cookie, Jan 25 2020 - 06:55 AM.


#3 Millennium

Millennium

    ErikGPL

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 552 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:GPL
  • Sim interest:GPL

Posted Jan 25 2020 - 08:54 AM

When you say there is no movement on the axis page, do you mean on the first page? Because like Cookie points out you can scroll through multiple pages. (Took me a while to figure this out as well)

GPL can also get confused when too many usb devices are plugged in, do you still get the same problem when just the mouse+keyboard+t300+pedals are plugged in and nonthing else?

Edited by Millennium, Jan 25 2020 - 08:55 AM.


#4 jgf

jgf

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 827 posts
  • Gender:Male
  • Location:Columbus, OH
  • Sim interest:GPL and P&G

Posted Jan 26 2020 - 12:34 PM

Try plugging the controllers into different ports.  As mentioned, GPL does not like like multiple controllers (I have to unplug my joystick or GPL will assign one pedal and one shifter to it ...and not allow me to reassign them in game), but you may find a combination of controllers/ports it will accept.

#5 Timo Vermeersch

Timo Vermeersch

    Guy Ligier

  • Members
  • Pip
  • 4 posts
  • Sim interest:GPL

Posted Feb 10 2020 - 01:53 PM

Hi guys,

thanks for the feedback. And sorry for the late reply.

So I tried to unplug everything from my USB ports: all external HD's; Elgato etc. Just the mouse, steering wheel, pedals and shifter connected.

Same result: GPL sees 7 axes but only turning the steering wheel yields a reaction. Pedals stay dead.

Probably just one of these things...

Thanks for the help anyhow.

Timo

#6 Michkov

Michkov

    Denny Hulme

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,024 posts
  • Gender:Male
  • Location:Graz
  • Sim interest:I am here to spam and wish to be deleted after registering

Posted Feb 10 2020 - 05:29 PM

GPLShift has a setting that enables more axis. Have a look at the ini, each entry has extensive documentation next to it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Sim Racing Links